1

Im trying to use the Tikz externalize, because for some tikz pictures the file gets to big and exceeds the memory size. I found a lot of other topics with similar problems, but non of the solutions worked for me or I did not implement them well enough. I'm using Winedt 10.2(also tried Winedt 9) Mixtex 2.9

The structure of the report:

Final_Report.tex
--Layout.tex
--Simulation_model.tex
----plot_baseunit.tex(Tikz picture)

Final_Report.tex

\documentclass[10pt,a4paper]{report}
\input{./Lay_out/layout.tex}`
\begin{document}
\input{./Chapters/Simulation_Model/Simulation_Model.tex}
\end{document}

layout.tex

\usepackage{tikz,pgfplots}
\usetikzlibrary{arrows,decorations.pathmorphing,shadows,fit,positioning,shapes,chains, plotmarks,automata,positioning}
\usepackage{subcaption}
%\usepackage[pdftex]{graphicx}
\usetikzlibrary{external,calc,patterns,angles,quotes,shapes.geometric,positioning}
\pgfplotsset{plot coordinates/math parser=false}
\tikzexternalize[prefix=figures/,shell escape=-enable-write18]
\newlength\figureheight
\newlength\figurewidth
%Standard figure dimension
\newcommand{\plotx}{12.0cm}
\newcommand{\ploty}{6.0cm}
\newcommand{\plotysub}{3.0cm} %y-dimension of seperate subplots
%Subplot dimensions (2 plots wide subplots)
\newcommand{\subtwoplotx}{5.25cm}
\newcommand{\subtwoploty}{4.5cm}
\tikzstyle{block} = [draw, rectangle, node distance=2.0cm, minimum height=3em, minimum width=4em]
\tikzstyle{sum} = [draw, circle, node distance=2.0cm]
\tikzstyle{input} = [coordinate]
\tikzstyle{output} = [coordinate]
\tikzstyle{pinstyle} = [pin edge={to-,thin,black}]

Simulation_model.tex

\begin{figure}[H]
\resizebox{\textwidth}{!}{%
\input{./figures/plot_baseunit.tex}
}%
\caption{The throughput and cycle time of the production line plotted against the process time of a base unit workstation, as bottleneck of the system. The horizontal dotted lines represent the designed throughput and cycle time of the Honda/JLR(green) and Audi/Porsche roof systems(purple).}
\label{fig:Base_unit_through}
\end{figure}

When I try to run this using PDFTeXify it gives the following error.

   (figures/plot_baseunit.tex
===== 'mode=convert with system call': Invoking 'pdflatex -halt-on-error -interaction=batchmode -jobname 
"figures/Final_Report-figure0" "\def\tikzexternalrealjob{Final_Report}\input{Final_Report}"' ========

! Package tikz Error: Sorry, the system call 'pdflatex -halt-on-error-interact
ion=batchmode -jobname "figures/Final_Report-figure0" "\def\tikzexternalrealjob
{Final_Report}\input{Final_Report}" 
did NOT result in a usable output file 
'figures/Final_Report-figure0' (expected one of .pdf:.jpg:.jpeg:.png:). 
Please verify that you have enabled system calls. For pdflatex, this is 'pdflatex -shell-escape'.
 Sometimes it is also named 'write 18' or something like that. Or maybe  the command simply failed?
 Error messages can be found in 'figures/Final_Report-figure0.log'. If you continue now, I'll try to typeset the picture.

If I just press enter the right figures come out, but this does not work for large files and then the memory size is exceeded.

Thanks in advance!.

  • 2
    Start with a simple example that doesn't involve subfolders and subfiles. When this work you can go on. – Ulrike Fischer Jun 24 '17 at 11:57
  • Have you really enabled system calls aka shell escapes (see the error message)? – Schweinebacke Jun 24 '17 at 12:03
  • The shell calls go into your editor, not the document you write. If you have problems with cumulative Tikz pictures exceeding the memory, try commenting all and uncomment once at a time. The pdf that is included with tikzexternalize take little to no TeX capacity, so on each run you only have a tikz picture to compile. – Huang_d Jun 24 '17 at 12:10
  • @Schweinebacke: Sorry, I read too hastily. Thanks for pointing the sentence. I'll remove my comment. – Bernard Jun 24 '17 at 13:33
  • 1
    How did you configure WinEdt to add -shell-escape (or --enable-write18) to the switches of pdflatex? – Bernard Jun 24 '17 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.