2

I am trying to implement the solutions that are found here to add a footnote that comes without a number, e.g. this or this one. But even using \Footnotetext{}{text} from nccfoots always produces a footnote that has no number but still a dot (from the numbering).

I am using the latest MacTeX-2017 distribution.

UPDATE: I am very sorry that I have not have provided a MWE sooner, but I got hold up in something...

Anyway, while preparing the MWE, I figured that the issue is related to a conflict with the biblatex-chicago package.

\documentclass{article}

\usepackage{lipsum}
\usepackage{nccfoots} % or any other method to supress numbers
\usepackage[
authordate,
backend=biber,
maxcitenames=2,
uniquelist=false
]{biblatex-chicago}

\begin{document}
\Footnotetext{}{A nccfoots footnote.}
\end{document}

If I delete \usepackage{biblatex-chicago} from the MWE, it will actually work. Otherwise the output looks as follows:

enter image description here

Do you see a workaround?

  • 1
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Michael Fraiman Jun 24 '17 at 16:26
  • Off-topic, but MacTEX is a distribution, not a package. – Michael Fraiman Jun 24 '17 at 16:27
  • I think you have to give \footnotetext{}{text} ... not capital first letter... (not tested) (Ignore it... I thought you did that in the second solution you gave .. not in the last) – koleygr Jun 24 '17 at 16:28
  • Wow - thanks for all the quick comments. Let try to get a MWE to work... – n1000 Jun 24 '17 at 16:33
1

Last answer (not-tested) but I read some of the manuals (I don't have biblatex-chicago really installed- just downloaded the '.sty; file). May by you can do it.

biblatex-chicago's author writes somewhere in the manual that he used some idea for the citation that leads to the bibtex documentation where I was looking to disable 'prenote'... But then back in his source, looking for prenote I found that he has a 'footmarkoff' option and it's used in all of his citations... So, 'disabling his footmark' by including 'footmarkoff' in the options of 'biblatex-chicago' we can solve the problem...

I suppose you don't want to lose the 'dot' from everywhere in your citation, so we will redefine our footnote command and define the phantomfootnote that (hopefully) will do what you need:

Here is the code:

\documentclass{article}

\usepackage{lipsum}
\usepackage{nccfoots} % or any other method to supress numbers
\usepackage[width=10cm,height=5cm]{geometry}
\usepackage[
authordate,
backend=biber,
maxcitenames=2,
uniquelist=false,
footmarkoff             % This option allows as to redefine footnotes
]{biblatex-chicago}



\let\origfootnote\footnote
\renewcommand*{\footnote}[1]{
\origfootnote{.\phantom{.}#1}}



\newcommand{\myphantfootnote}[1]{%
  \let\xxxx\thempfn
  \let\thempfn\relax
  \footnotetext{\phantom{..}#1}
  \let\thempfn\xxxx% Print footnote text
}


\begin{document}


Here is a text with a normal footnote.\footnote{A first footnote.}

Another one here.\footnote{Second footnote}


Here a phantom one.\myphantfootnote{Test}

And here we want number 3.\footnote{An Aligned 3. here :)}
\end{document}

And the output (I have disabled many options of the package and I don't rally know if it gives the same output for others):

enter image description here

Good Luck!

| improve this answer | |
  • Thank you! The MWE will work once I comment out smartcites=false. Was there a reason you included that? You may want to remove it from your answer. – n1000 Jun 25 '17 at 18:44
  • Ok... removed... may be I could not compile or I forgot it there from previous tests... – koleygr Jun 25 '17 at 18:50
2

Here is what you can do:

\documentclass[a4paper,10pt]{article}
\usepackage[utf8]{inputenc}

%opening

\let\origfootnote\footnote
\renewcommand{\footnote}[1]{\kern.06em\origfootnote{.#1}}


\newcommand{\chapternote}[1]{{%
  \let\thempfn\relax% Remove footnote number printing mechanism
  \footnotetext[0]{\phantom{.}#1}% Print footnote text
}}

\title{}

\begin{document}



\section{Test section}

here is a footnoted text\footnote{text in footnote}

here is a second footnoted text\footnote{text in 2 footnote}

here is your desired third footnoted text\chapternote{text in 3 footnote}

here is a last footnoted text\footnote{test... has to be numbered as 3 with dot}


\end{document}

Result:

enter image description here

| improve this answer | |
  • 1
    the comand '\let\origfootnote\footnote \renewcommand{\footnote}[1]{\kern.06em\origfootnote{.#1}}' just added to reproduce your problem and of course you can ignore it... You already have a similar command in your document – koleygr Jun 24 '17 at 16:57
  • 1
    I am extremely sorry, that I did not quickly provide the MWE. I got hold up... I updated the question. – n1000 Jun 25 '17 at 5:09
2

Here is an other answer using scrbook

\documentclass[a4paper,10pt]{scrbook}
\usepackage[utf8]{inputenc}
\usepackage[width=13cm,height=10cm]{geometry}

\newif\iffootpunct
\footpuncttrue

\deffootnote[1.7em]{1.6em}{2em}{\thefootnotemark\iffootpunct.\fi\enskip}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%



\long\def\asteriskfootnote#1{\begingroup%
\footpunctfalse
\def\thefootnote{\fnsymbol{footnote}}\footnote[1]{#1}\endgroup} 


\makeatletter
\long\def\blindnote#1{\begingroup
  \let\thempfn\relax% Remove footnote number printing mechanism
  \footpunctfalse
  \footnotetext{#1}% Print footnote text
  \endgroup
  }
\footpuncttrue
\makeatother
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%


\title{}

\begin{document}



\chapter{Test chapter}

\section{Test section}
here is a footnoted text\footnote{text in footnote 1}

here is a second footnoted text\footnote{text in  footnote 2... counts ok}

here is your desired third footnoted text\blindnote{text in footnote 3... no dot no count}

here is a last footnoted text\footnote{test... has to be numbered as 3 with dot}

And ofcourse you can use anywhare a \verb|\footnotemark| like here\footnotemark{} containing a fourth text

\footnotetext{fourth footnote text}

\end{document}

The output:

enter image description here

The problem is that you never added a working example and we can not know what would really help you...

The problem with your question is that somewhere in your file is redefined the footnote or the footnotetext. If the footnote is redefined the solution is easy as in my first answer... If the redefined command is the footnotetext I think that the easier way is to change this definition

| improve this answer | |
  • Again, my apologies... Unfortunately, both of your solutions do not work. Here I get Undefined control sequence. l.54 \deffootnoteand the other one has no effect. – n1000 Jun 25 '17 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.