1

This question already has an answer here:

Explanations:

I'm trying to migrate from natbib to biblatex.
I don't know if it's a good idea but according to some links under, it seems like.

Anyway, I'm having some small issues yet:

When there is several authors to some paper, in the References, the first author is written so:

Robert, J.

-> last name first and first letter of first name.
OK. It's what I want.

But then, all other authors are listed so:

J. Haking, and Matthew Haris

so first letter of (or full) first name and then last name.
So it's the inverse as the first author!

Questions:

Question 1: same arrangement in names;

I wonder if it's the normal behavior and how could I have the same arrangement, i.e. Last Name first, and then first letter of first name for every authors listed?

Question 2: get initial of first names;

Is there a way to force an initial-like display for the first name instead of the full first name?
I currently have a disgusting mix of these 2...
Yes, I know, I can (should) make this properly within the *.bib file...
But then, if I write down the full first name in the *.bib file and I would like the abbreviated form in my References, how could I achieve that?

Question 3: same author for 2 papers;

I have once the same author for two different papers. Fine. But the second one is figured out so:

— (2005). "Title" ....

There is a big hyphen instead of the author name. I guess it's because it's already in the reference just above, but I find it ugly.
Again, is this behavior normal and is there a way to force the author name to be written here?

Code:

I'm currently calling biblatex in the preamble like:

% Biblatex bibligraphy:
\usepackage[
backend=bibtex,
style=authoryear,
citestyle=authoryear-comp,
natbib=true,
sorting=nyvt, % https://tex.stackexchange.com/questions/51434/biblatex-citation-order
doi=false,isbn=false,url=false
]
{biblatex}
\setlength\bibitemsep{0.64\baselineskip}
% \bibliography{<mybibfile>}% ONLY selects .bib file; syntax for version <= 1.1b
\addbibresource{biblio.bib}% Syntax for version >= 1.2
%%%%%%%%%%%%%%%%%%%%%%%%

And in the document at the right place where I want the References:

\newpage{}
\markboth{References}{References}
\addcontentsline{toc}{chapter}{References} 
\nocite{*}
% Biblatex bibligraphy:
\printbibliography%[]

Useful links:

bibtex vs. biber and biblatex vs. natbib
What to do to switch to biblatex?
Biblatex citation order

Natbib biblio' styles: https://fr.sharelatex.com/learn/Natbib_bibliography_styles
Natbib citation style: https://fr.sharelatex.com/learn/Natbib_citation_styles
Biblatex biblio' styles: https://fr.sharelatex.com/learn/Biblatex_bibliography_styles
Biblatex citation styles: https://fr.sharelatex.com/learn/Biblatex_citation_styles


Update:

MWE:

test.tex content:

\documentclass[a4paper,12pt,twoside]{report}
\usepackage[utf8]{inputenc}
\usepackage[british,UKenglish,USenglish,english,american]{babel}
\usepackage[T1]{fontenc}
\usepackage[
backend=bibtex,
style=authoryear,
citestyle=authoryear-comp,
natbib=true,
sorting=nyvt,
doi=false,isbn=false,url=false
]
{biblatex}
\setlength\bibitemsep{0.64\baselineskip}
\addbibresource{ref.bib}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\begin{document}

\newpage{}
\markboth{References}{References}
\addcontentsline{toc}{chapter}{References} 
\nocite{*}
\printbibliography

\end{document} 
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

ref.bib content:

@INPROCEEDINGS{item1,
author={F. LastName1 and G. LastName2 and Haris LastName3},
booktitle={1574 International Conference on LaTeX },
title={Kings in Europe},
year={1574},
pages={2-4},
month={Jun}
},

@inproceedings{item2,
    title       =    "Trees are not animals",
    author      =    "Mike Haking and John Roberts",
    year        =    "1575",
    month       =    "November",
    pages       =    "18--20",
    volume      =    "8",
    booktitle   =    "IEEE International Conference on E-Documents processing",
},

@inproceedings{item3,
    title       =    "Travel through time",
    author      =    "Mike Haking and John Roberts",
    year        =    "2098",
    month       =    "May",
    pages       =    "4--8",
    volume      =    "1",
    booktitle   =    "American Conference on Time Traveling"
}

Results in:

output bib

marked as duplicate by moewe biblatex Jul 1 '17 at 7:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Under BibTeX, the formatting of the bibliographic entries is not determined by natbib but by the bibliography style. Which style have you employed so far? – Mico Jun 25 '17 at 13:21
  • Isn't the style described within the call to biblatex as in my code above? : style=authoryear, – s.k Jun 25 '17 at 13:32
  • authoryear style refers to the way the citation call-outs are formatted; it's not directly related to the way the bibliographic entries are formatted. – Mico Jun 25 '17 at 13:39
  • I thought this was the citestyle. So what is the citestyle parameter about? And how would you precise a citation style within the References? – s.k Jun 25 '17 at 13:42
  • Could you post a full, yet minimal compilable code? – Bernard Jun 25 '17 at 13:43
2

As I found some answers, I post them here:

Answers:

Answers 1: same arrangement in names;

It's the normal behavior for style authoryear.
To change it, one has to add this line in the preamble after importing biblatex:

\DeclareNameAlias{sortname}{last-first}

Answers 2: get initial of first names;

The way to get only initials for first names is to add this in the options [] of biblatex when importing it:

firstinits=true,   

Answers 3: same author for 2 papers;

The way to get rid of the hyphen for multiple same authors is to add this in the options [] of biblatex when importing it:

dashed=false,   

This results in:

output bib

Source:

These tips (as many others) come from: Guidelines for customizing biblatex styles Thanks to lockstep.

Other useful links:

Delete "In:" before journal: Suppress "In:" biblatex

  • 2
    Ad 1) with versions older than 3.3 of biblatex you need \DeclareNameAlias{sortname}{family-given}. It is 'normal' that you get only the first name inverted by default. The idea behind that might be that the 'natural' order is 'First Last', but bibliography items are sorted by author (last) names, so the name that is used for sorting is inverted because you see the last name first. – moewe Jun 25 '17 at 15:15
  • 2
    Ad 2) with post-3.3 versions of biblatex the option is called giveninits, the old name will generate a warning. – moewe Jun 25 '17 at 15:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.