1

Currently this is the content of my bib file:

@Article{RMPM,
  author =       "B. Wang, M.A Hicks, P.J. Vardon",
  title =        "Slope failure analysis using the random material point method",
  volume =       "6",
  number =       "2"
  pages =        "113-118",
  year =         "2016",
  DOI =          "http://dx.doi.org/10.1680/jgele.16.00019"
} 

@Article{RFEM,
  author =       "M.A Hicks, W.A. Spencer",
  title =        "Influence of heterogeneity on the reliability and failure of a long 3D slope",
  volume =       "37",
  number =       "7-8"
  pages =        "948-955",
  year =         "2010"
  DOI =          "http://dx.doi.org/10.1680/jgele.16.00019"
} 

I would like this to give me a clean set of journal references with numbered indices similar to those shown here. However what I'm getting is something along the lines ofenter image description here

Firstly, the "References" caption is way too high up above the bibliography.

Secondly, the references are not numbered. When I cite them the citation appears as the full name of the authors+the date which is not what I'm looking for. I would prefer a numbered citation instead...

Thirdly, the journal-related fields are not showing in my list of references. As can be seen from the bib file I am providing a date, page numbers and a DOI which do not appear in the bibliography itself.

The code from my tex file is shown below:

\documentclass[jou,apacite]{apa6}
\usepackage{graphicx}
\title{Brief literature review}
\shorttitle{APA style}

\author{Name}
\affiliation{affiliation}

\abstract{This is a brief literature review for both documents provided by }

\rightheader{APA style}
\leftheader{Author One}

\begin{document}
\cite{RMPM,RFEM}

\bibliography{Ref}

\end{document}

Where Ref.bib is the bib file.

How can I get Texmaker to give me numbered references and fix the journal entry problems as explained above?

  • Welcome to TeX.SX! Please help us (and also you) and add a minimal working example with bibliography (MWEB), that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass and ending with \end{document}. – Bobyandbob Jun 25 '17 at 13:34
  • Allright I'll do that and edit the question. – user32882 Jun 25 '17 at 13:34
  • Here you can find different bibliography styles: sharelatex.com/learn/Bibtex_bibliography_styles also with numbered citation. – Bobyandbob Jun 25 '17 at 13:35
  • 2
    Use and not a comma to separate authors. – Johannes_B Jun 25 '17 at 13:39
1

First off, the apacite bibliography style is meant to generate authoryear-style citation call-outs, not numeric citation call-outs. If you must create numeric citation call-outs, don't use the apacite bibliography style. That said, since you're using the apa6 document class, I can't see why you would want to choose anything but authoryear-style citation call-outs.

Second, the two bib entries you've posted contain several egregious errors.

  • Use the keyword and to separate authors. Do not use commas for this purpose.

  • Each field must be terminated by a comma. Currently, the first entry is missing one comma field terminator, while the second entry is missing two [2!] comma field terminators.

  • For entries of type @article, the field journal is required. However, this information is missing in both entries.

Here's a suggestion for a partial edit.

@Article{RMPM,
  author =       "B. Wang and M. A. Hicks and P. J. Vardon",
  title =        "Slope failure analysis using the random material point method",
  journal =      "aaa bbb ccc",
  volume =       "6",
  number =       "2",
  pages =        "113-118",
  year =         "2016",
  DOI =          "http://dx.doi.org/10.1680/jgele.16.00019"
} 

@Article{RFEM,
  author =       "M. A. Hicks and W. A. Spencer",
  title =        "Influence of heterogeneity on the reliability and failure of a long {3D} slope",
  journal =      "aaa bbb ccc",
  volume =       "37",
  number =       "7-8",
  pages =        "948-955",
  year =         "2010",
  DOI =          "http://dx.doi.org/10.1680/jgele.16.00019"
} 

Here's a full MWE. Observe that, in addition to implementing the suggestions given above, (a) I've changed - to -- in the pages and number fields and (b) the url package is loaded explicitly, with the option hyphens. Obviously, you'll need to supply the correct journal names.

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{Ref.bib}
@Article{RMPM,
  author =       "B. Wang and M. A. Hicks and P. J. Vardon",
  title =        "Slope failure analysis using the random material point method",
  journal =      "abc def ghi",
  volume =       "6",
  number =       "2",
  pages =        "113--118",
  year =         "2016",
  DOI =          "http://dx.doi.org/10.1680/jgele.16.00019"
} 

@Article{RFEM,
  author =       "M. A. Hicks and W. A. Spencer",
  title =        "Influence of heterogeneity on the reliability and failure of a long {3D} slope",
  journal =      "jkl mno pqr",
  volume =       "37",
  number =       "7--8",
  pages =        "948--955",
  year =         "2010",
  DOI =          "http://dx.doi.org/10.1680/jgele.16.00019"
} 
\end{filecontents}
\documentclass[jou,apacite]{apa6}
\usepackage{graphicx}
\usepackage[hyphens]{url}
\usepackage{lipsum} % filler text
\title{Brief literature review}
\shorttitle{APA style}

\author{Name}
\affiliation{Affiliation}

\abstract{This is a brief literature review for 
both documents provided by \dots}

\rightheader{APA style}
\leftheader{Author One}

\begin{document}
\maketitle
\lipsum[1] % filler text

As argued by \citeA{RMPM} and \citeA{RFEM}, \dots

\bibliography{Ref}
\end{document}
  • Thanks for your response and helping me pick out these errors. However 2 problems persist. The "References" caption is still way up there, looking like regular text with excessive spacing and not like a caption at all. The years of publication still do not appear. Furthermore removing apacite throws me into a world of hurt. I'd like to get rid of it, but how to do so as smoothly as possible? – user32882 Jun 25 '17 at 13:58
  • @user32882 I've posted a full MWE (minimum working example). Incidentally, if you don't use the apacite package and bibliography style, you need to specify an alternative. Simply removing the apacite option from the \documentclass directive has no chance of working. – Mico Jun 25 '17 at 14:17
  • I guess not. Perhaps I need to be using a different \documentclass? I am looking to do something like this: ctp.itp.ac.cn/EN/article/downloadArticleFile.do?attachType=PDF&id=11180 – user32882 Jun 25 '17 at 14:18
  • @user32882 The linked document definitely uses authoryear-style rather than numeric citation call-outs. – Mico Jun 25 '17 at 14:20
  • 2
    @user32882 - If this is a "pure self-learning exercise" and no special formatting requirements are present, I would definitely not use the apa6 document class. I'd probably just go with the article document class, the natbib citation management package (with the option numbers, to create numeric-style citation call-outs,, and the plainnat bibliography style. – Mico Jun 25 '17 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.