0

How to justify the line in latex beamer presentation. Using below code I am using to make a slide presentation which I attached below, but the text is not appearing good decorate. I tried to used \Justifying command but it's not working.

The second paragraph of the slide does not look well decorate the text.

\documentclass[handout,t]{beamer}
\begin{document}
\usepackage{ragged2e}
% -----------------------------------------------------------------------------
\begin{frame}{District wise Cumulative Rainfall as on 23rd June, 2017}
\begin{columns}[onlytextwidth,T]
    \begin{column}{.45\textwidth}
        \includegraphics[width=\textwidth]{MONSOON-CUMULATIVE}
    \end{column}
    \begin{column}{.47\textwidth}
        \begin{itemize}
%%          \JustifyingParfillskip
%           \JustifyingParindent
            \item Central and North part of the regions under deficit category of rainfall (yellow and red zones). 
            \item The excess rainfall received in Bharuch, Narmada and Dahod while others region received normal rainfall (Green and blue zones). 
        \end{itemize}
    \end{column}
\end{columns}
\end{frame}
\end{document}
%------------------------------------------------------------------------------

enter image description here

  • 1
    You cannot use a package after \begin{document}. – TeXnician Jun 26 '17 at 5:53
  • Ok. What's the another way to do it – SWAT Jun 26 '17 at 5:56
  • 2
    Use it before \begin{document} (even TeX gives you this tip in the error message). – TeXnician Jun 26 '17 at 5:56
2

Your code has two primary issues:

  • You have a \usepackage outside of the preamble and
  • you use an inexistent macro \Justifying (ragged2e defines \justifying)

justified

\documentclass[handout,demo,t]{beamer}
\usepackage{ragged2e}
\begin{document}
% -----------------------------------------------------------------------------
\begin{frame}{District wise Cumulative Rainfall as on 23rd June, 2017}
\begin{columns}[onlytextwidth,T]
    \begin{column}{.45\textwidth}
        \includegraphics[width=\textwidth]{MONSOON-CUMULATIVE}
    \end{column}
    \begin{column}{.47\textwidth}
        \begin{itemize}
            \item\justifying Central and North part of the regions under deficit category of rainfall (yellow and red zones). 
            \item The excess rainfall received in Bharuch, Narmada and Dahod while others region received normal rainfall (Green and blue zones). 
        \end{itemize}
    \end{column}
\end{columns}
\end{frame}
\end{document}
  • Thank you. but problem is \justifying command is not appearing in my beamer presentation. When i type J its showing one two option \JustifyingParfillskip \JustifyingParindent. – SWAT Jun 26 '17 at 6:16
  • @SWAT What do you mean with not appearing? Syntax auto completion? That's no indicator for commands! Just try to compile my file and it works. – TeXnician Jun 26 '17 at 6:18
  • @SWAT If you don't believe me, just check out the ragged2e manual. – TeXnician Jun 26 '17 at 6:19
  • Thank you very much. It was a just space issue. Now it's working perfectly. – SWAT Jun 26 '17 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.