1

I had followed the instructions given in the answer to a similar question, but it seems that sage never gets launched once pdf is created in that integration. I am attaching screenshot of log and messages which popped up.

enter image description here

Due to my desperation, I tried using Latexmk to do this job. After learning what is .latexmkrc/LatexMk file (hopefully), I tried to build one as as described here, although very naively. I just copied and pasted the code given in a fresh text and placed it in $HOME/.latexmkrc.

I ran the command latexmk myfile.tex and it gave me only PDF again, without running sage. I am sorry but I am unable to find a way to copy/paste huge amount of data my terminal spouted out. I will wait for you to tell me what specifically to post out of it.

Interesting point: Just once and no more, when using latexmk myfie.tex, terminal recongzied the RC file in home directory and said there are errors in it.

I just want a way to click a button and compile my documents, doesn't matter which way. I beg you people to lend me a hand. Will be very grateful.


I am on Linux Mint 18.1, currently a noob. Using TeX for quite some time now, thanks to TeX community. Will try my best to follow your instructions.

  • There are instructions for integrating Kile with sagetex here using lots of pictures. I tried them with my computer (Linux Mint 18.1). The interface with Kile looks different now (post was written in 2013) but I got it to work in less than 10 minutes of tinkering. – DJP Jul 1 '17 at 3:12
  • Thankyou for reply. I tried this already. I tried again, for the heck of it. After choosing type as "Run Sequence of Tools", If I choose the class "compile", [as this link suggests] I get nothing at all. However, if I choose the "sequence" class I get what is in the image. Any suggestion? – physicophilic Jul 1 '17 at 13:53
  • Problem is in SAGE. I tried to run it separately and it shows the same error as above - failed to start [SAGE] failed to start – physicophilic Jul 1 '17 at 14:04
  • The error in your picture about Sage failed to start indicates, I think, that Sage never ran. Some possible things to check: 1. ' marks as in : '%S.sage' 2. Two tools under build--I called one Sage which is Type Run outside of Kile and Class Compile. The second tool I called SagePDF which is Type Run Sequence of Tools and Class Sequence. Under the General tab it is tool Archive, Current Default tar +gzip. 3. the box next to the Add/Remove/Up/Down buttons it says PDFLaTeX above Sage above PDFLaTeX above ViewPDF. Mine says Sage rather than the SAGE (as in link) because that's my Tool. – DJP Jul 1 '17 at 16:06
  • Try opening a terminal and typing: sage to see if sage starts, too. Sage is not part of LaTeX distribution, so it needs to be installed on your machine and this link talks about making sure Sage and LaTeX are talking to one another. – DJP Jul 1 '17 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.