1

Why is that most of the words, almost 90 percent, are marked as misspelled words when there is no error? And the spellchecking suggestions don't even look like English.

I am using TeXstudio as my editor.

  • 1
    Welcome to TeX SE! There is no way anyone will be able to answer this question as is. At the very least, you're going to need to say what your text editor is. – TH. Jul 1 '17 at 6:43
  • 2
    The program pdfTeX does not mark any word as misspelled, because it does not contain a spell-checker. Name the programs you are using (editor, IDE or whateever), the language, and maybe an example. – Heiko Oberdiek Jul 1 '17 at 6:43
  • I am new to this software. Actually I am writing a document for a conferenc. I dont actually know whether it is pdfTeX. I couldnt post this question without a tag and I couldnt make a new tag as I am a newcomer. My code begins like this \documentclass[conference]{IEEEtran} \usepackage[utf8]{inputenc} \usepackage[english]{babel} \usepackage{amsmath} \usepackage{amsfonts} \usepackage{amssymb} \usepackage{makeidx} \usepackage{graphicx} \usepackage{setspace} \usepackage{fancyhdr} \ifCLASSINFOpdf \else \fi \hyphenation{op-tical net-works semi-conduc-tor} – malu k raj Jul 1 '17 at 6:50
  • 1
    Which is your EDITOR (the program you use to write your LaTeX code)? – karlkoeller Jul 1 '17 at 6:56
  • I think texstudio is my editor. And language is English. – malu k raj Jul 1 '17 at 7:10
8

You can change the spellcheck language in the options:

Options -> Configure TeXstudio -> Language Checking (on the left) -> Default language: and choose en_GB for British english, for example.

enter image description here

Another (quicker) way is to change it from the language options on the bottom right of TeXstudio UI.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.