1

The compilation of this tex code

\documentclass{article}

\usepackage[utf8]{inputenc}

\usepackage[natbib, maxcitenames=3, style=authoryear]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{bib.bib}
@ARTICLE{G2000,
  author = {{Gondek-Rosi{\'n}ska}, D. and {Bulik}, T. and {Zdunik}, L. and 
    {Gourgoulhon}, E.},
  year = 2000
}
@ARTICLE{G2007,
  author = {{Gondek-Rosi{\'n}ska}, D. and {Bejger}, M. and {Bulik}, T. and 
    {Gourgoulhon}, E.},
  year = 2007
}
\end{filecontents}
\addbibresource{bib.bib}

\begin{document}
\citep{G2000}\\
\citep{G2007}\\
\end{document}

gives the output of:

(Gondek-Rosińska, Bulik, et al., 2000)

(Gondek-Rosińska, Bejger, et al., 2007)

But when I change the first author's surname to Gandek-Rosi{\'n}ska i get the following (desired) output:

(Gandek-Rosińska et al., 2000)

(Gondek-Rosińska et al., 2007)

Actually, changing the name to Kondek-Rosi{\'n}ska or any other name works as expected, i.e. gives only the first author name followed by et al.. Why such strange behaviour? I compile the code on the sharelatex.com.

marked as duplicate by user36296, Community Jul 1 '17 at 20:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • In one way it's not strange, it's to emphasize that you're talking about two different groups of authors. Same as in tex.stackexchange.com/questions/17838/… I guess, so you can try that. biblatex and biber has undergone a lot of development the last years though, so I'm not completely sure that it still applies. – Torbjørn T. Jul 1 '17 at 20:15
4

Not a bug, but a feature to differentiate between the two publications of the same first author. To disable it, you can set uniquelist=false.

\documentclass{article}

\usepackage[utf8]{inputenc}

\usepackage[natbib, maxcitenames=3, style=authoryear, uniquelist=false]{biblatex}

\usepackage{filecontents}
\begin{filecontents}{bib.bib}
@ARTICLE{G2000,
  author = {{Gondek-Rosi{\'n}ska}, D. and {Bulik}, T. and {Zdunik}, L. and 
    {Gourgoulhon}, E.},
  year = 2000
}
@ARTICLE{G2007,
  author = {{Gondek-Rosi{\'n}ska}, D. and {Bejger}, M. and {Bulik}, T. and 
    {Gourgoulhon}, E.},
  year = 2007
}
\end{filecontents}
\addbibresource{bib.bib}

\begin{document}
\citep{G2000}\\
\citep{G2007}\\
\end{document}

Not the answer you're looking for? Browse other questions tagged or ask your own question.