2

This seems to me to be weird. I can't find any references to anything similar happening, the nearest I find is when a [?] appears instead of the author when using BibTeX.

Six months ago, I compiled a thesis, it worked fine, the references appeared fine. On a new computer, a new install of TeXmaker (4.4.1). Now, instead of author/year appearing in the text, the title of the article being referenced appears.

I took some of the preamble from the text file to create a minimal working example of the problem. My tex file now consists of:

\documentclass[12pt, english, onehalfspacing, liststotoc, toctotoc, parskip,]{MastersDoctoralThesis}        
\usepackage[backend=bibtex,style=authoryear,natbib=true,bibencoding=ascii,dashed=false]{biblatex}
%\DeclareNameAlias{author}{last-first}
\usepackage[titletoc]{appendix}% http://ctan.org/pkg/appendices
\addbibresource{minimal.bib} % The filename of the bibliography
\usepackage[autostyle=true]{csquotes} 

\begin{document}
\tableofcontents
blah blah blah\citep{Nicholson1992}
\printbibliography[heading=bibintoc]
\end{document}

My bib file consists of:

Automatically generated by Mendeley Desktop 1.17.10
Any changes to this file will be lost if it is regenerated by Mendeley.
BibTeX export options can be customized via Options -> BibTeX in Mendeley Desktop

@article{Nicholson1992,
author = {Nicholson, R L and Hammerschmidt, R},
doi = {10.1146/annurev.py.30.090192.002101},
issn = {0066-4286},
journal = {Annual Review of Phytopathology},
number = {1},
pages = {369--389},
publisher = {Annual Reviews, Palo Alto, USA},
title = {Phenolic Compounds and Their Role in Disease Resistance},
url = {http://www.annualreviews.org/doi/abs/10.1146/annurev.py.30.090192.002101},
volume = {30},
year = {1992}
}

If I run

pdflatex minimal.tex 
bibtex minimal
pdflatex minimal.tex 
pdflatex minimal.tex 

I get no errors, only a warning:

Package biblatex Warning: File 'minimal.bbl' created by wrong version.

Otherwise, it produces a pdf with the following in the text body:

blah blah blah(“Phenolic Compounds and Their Role in Disease Resistance”)

Where do I start looking for a solution for this?

closed as off-topic by moewe, Stefan Pinnow, Sveinung, CarLaTeX, Adam Liter Jul 5 '17 at 14:00

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Well the Package biblatex Warning: File 'minimal.bbl' created by wrong version. is crucial. That means that something is out of sync. Try updating your TeX distribution. Then delete all temporary files and try again. BTW: Would it be an option to use Biber? – moewe Jul 5 '17 at 11:37
  • Are you on Windows? Do you use TeX live or MikTeX? – moewe Jul 5 '17 at 11:39
  • I'm using Mint. I've updated repository's and Texlive is at the latest version as best I can tell. – Ben Jul 5 '17 at 11:55
  • Do you use TeX live from the repositories or vanilla? Can you check your biblatex version? – moewe Jul 5 '17 at 11:56
  • 4
    I'm voting to close this question as off-topic because it was caused by an outdated file in the working directory that masked the file of the package installed via the distribution. After deleting the spurious file everything works fine again. – moewe Jul 5 '17 at 12:39