0

When I try and install a new package via the MiKTeX package manager I get the error 'Unsupported protocol'. I'm not sure what this protocol is or where I can change it. The error information is:

MiKTeX Problem Report
Message: Unsupported protocol
Data: 
Source: Libraries\MiKTeX\PackageManager\CurlWebSession.cpp
Line: 402
MiKTeX: 2.9
OS: Microsoft Windows 7 Business Edition, 64-bit Service Pack 1 (build 7601)
Invokers: explorer/mo
SystemAdmin: no
PowerUser: no
Root0: C:\Users\~\AppData\Roaming\MiKTeX\2.9
Root1: C:\Users\~\AppData\Local\MiKTeX\2.9
Root2: C:\ProgramData\MiKTeX\2.9
Root3: C:\Program Files (x86)\MiKTeX 2.9
UserInstall: C:\Users\~\AppData\Roaming\MiKTeX\2.9
UserConfig: C:\Users\~\AppData\Roaming\MiKTeX\2.9
UserData: C:\Users\~\AppData\Local\MiKTeX\2.9
CommonInstall: C:\Program Files (x86)\MiKTeX 2.9
CommonConfig: C:\ProgramData\MiKTeX\2.9
CommonData: C:\ProgramData\MiKTeX\2.9

Any suggestions would be much appreciated.

6
  • Same question here but still not solved(accepted).
    – Bobyandbob
    Jul 5, 2017 at 19:25
  • You both have window 7. Perhaps it is specific to this os. In any case this here is the wrong place to report such problems. Make a bug report in the miktex tracker. sourceforge.net/p/miktex/bugs/?source=navbar. Jul 5, 2017 at 19:31
  • There is some suggestion that this may be due to a broken update to MiKTeX, however, I'm not sure how to update MiKTeX (with the update manager which is broken!). tex.stackexchange.com/questions/345485/miktex-update-error
    – 218
    Jul 5, 2017 at 19:31
  • Ulrike, to create a bug report on the site you suggest I need to be authorised to do so by the project admin. I don't have that permission.
    – 218
    Jul 5, 2017 at 19:34
  • Everyone can add a bug report to the tracker. You only need (perhaps) to register to sourceforge. Jul 5, 2017 at 20:46

2 Answers 2

1

Just created a bug report at miktex (this might indeed be a different issue than the "update error" one created by 218). https://sourceforge.net/p/miktex/bugs/2609/

[edit] and it has just been fixed apparently. (thanks to Christian Schenk). It works on my Win7 machine now and I did not reinstall anything.

0

This was driving me crazy! I was not able to install any packages even manually!

However, If you have the patience, try uninstall and re-install MiKTeX again and the error will go away!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .