1

I am receiving the following error message:

Running miktex-makemf.exe...

miktex-makemf: The source file could not be found. Running hbf2gf.exe...

hbf2gf (CJK ver. 4.8.0) `' can't be a subfont created by hbf2gf miktex-maketfm

: No creation rule for font ""

I have tried to tried to execute 'initexmf --update-fndb' and 'initexmf --mkmaps', but the error message remains. Can anyone help?

I suspect that is due to using package '\usepackage{pxfonts}'. A minimal working is extremely simple (see below). Reinstalling the package pxfonts also did not resolve the issue.

\documentclass[10pt]{book}
\usepackage{pxfonts} 
\begin{document}
hi
\end{document} 
  • 2
    Does it work if you add \pdfmapfile{=pdftex35.map} to your document? – Ulrike Fischer Jul 6 '17 at 14:07
  • Try running updmap --verbose from the command line. – Bernard Jul 6 '17 at 15:50
  • Please answer these questions: 1. Which LaTeX editor are you using? 2. When you compiled your document, did you have internet connection? 3. Have you already tried fixing the issue with MikTeX Package Manager? On my system, TeXSudio simply asked if I want to install the mentioned package and then compiled just fine. I suspect that something is wrong with your installation. – Gregor Perčič Jul 6 '17 at 16:55
  • @UlrikeFischer, your suggestion fixed the issue. Could you elaborate a bit on what the prolem was and how your recommendation solves it? – user80032 Jul 9 '17 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.