0

It turns out that TexMaker, after compiling several times, crashes when I compile another one. First it appeared: "Error: file not found", and then TexMaker closes and then dozens of alerts of "Close Firefox" appear, and a tap with "Questions for Files" appears too. I haven't used TexMaker too much in this laptop, but I had never experienced this. When I try to compile a beamer, it's even worse: the whole laptop crashes, and lots of tabs with the "Questions for Files" appear. I add some screenshots.

enter image description here

enter image description here

enter image description here

I've recently installed (but I'd say TexMaker crashed before too) some ubuntu-restricted-extras , exactally this, for Spotify , just in case it has something to do.

The laptop is a bit dizzy these days, maybe because of that or maybe this was caused by other thing (it didn't recognize my password once, it indicated 18 hours of battery life - whereas I only have around 3).

Thanks in advance

  • 2
    Back up your files, format your hard disk and reinstall operation system and all application from scratch. – Sveinung Jul 10 '17 at 10:50
  • @Sveinung Is there any explanation for this issue? Thanks. – Minkowski Jul 10 '17 at 11:01
  • 1
    Probably, but I do not have any. Maybe you have a disk error, a corrupted dll; there are zillion possibilities. However, you should safeguard your valuable work and back up in case a major disaster happens. After backing up, you may try to uninstall the programs that give errors (Firefox and Texmaker). Try compiling a tex file with another program and see what happens. If this works, you may try to re-install the application you uninstalled. – Sveinung Jul 10 '17 at 12:18
  • 3
    Your description indicates you have a creeping error that will evolve to a disaster sooner than later. – Sveinung Jul 10 '17 at 12:25
1

Update. I uninstalled and reinstalled Elementary Loki in my laptop, installed TeXLive 2017 (instead of TeXLive 2015 which is the version that appears in the repositories),... and the same issue happened again. My laptop crashed in the same way.

It seemed that using Gedit and by compiling in the command line it worked properly. I installed TeXStudio, and I even by forcing it I couldn't make it crash. It had to be TeXMaker... . Also, it only crashed when I made a quick build.

Thing is, my laptop is a Lenovo, and in order to compile quick I have to press Fn+F1. After adding a keyboard, I realized that it didn't crashed with it. So here you have. The problem came because I have to press Fn+F1 (funny thing, because in TeXStudio I had to press Fn+F6 and it worked).

Solution. I only had to change the "HotKey" Lenovo has in its laptops. It can be seen how to change the F1 key so you only have to press the F1 key instead Fn+F1 here.

Remark. I have pointed the problem and suggested a solution (so far), but I don't know the reason of the problem, I mean, I still don't know why it crashes with Fn+F1 in TeXMaker, and neither why it doesn't with TeXStudio. If somebody has any idea please comment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.