1

I'm using the ACM template here. I use the sample-sigconf.tex. When I open it and try to compile it, the Tex Studio reports the following error:

Process started: pdflatex.exe -synctex=1 -interaction=nonstopmode "sample-sigconf".tex

Unfortunately, the package acmart could not be installed.Please check the log file: C:/Users/username/AppData/Local/MiKTeX/2.9/miktex/log/pdflatex.log

Process exited with error(s)

Every time I tried to compile, there is a pop up window titled Package Installation, saying acmart is missing and whether you want to install it. I always choose yes but it always reports cannot install like above.

What's wrong with my installation?

The log information is as follows:

2017-07-10 17:36:21,388+0800 INFO  pdflatex - installing package acmart triggered by tex\latex\acmart\acmart.cls
2017-07-10 17:36:23,589+0800 INFO  pdflatex - mpm: starting package maintenance...
2017-07-10 17:36:23,589+0800 INFO  pdflatex - mpm: installation directory: "C:\Users\fengchao.pfc\AppData\Local\Programs\MiKTeX 2.9"
2017-07-10 17:36:23,589+0800 INFO  pdflatex - mpm: package repository: http://ftp.yzu.edu.tw/CTAN/systems/win32/miktex/tm/packages/
2017-07-10 17:36:23,590+0800 INFO  pdflatex - mpm: visiting repository http://ftp.yzu.edu.tw/CTAN/systems/win32/miktex/tm/packages/...
2017-07-10 17:36:23,590+0800 INFO  pdflatex - mpm: repository type: remote package repository
2017-07-10 17:36:23,590+0800 INFO  pdflatex - mpm: loading lightweight database...
2017-07-10 17:36:23,592+0800 INFO  pdflatex - mpm: downloading http://ftp.yzu.edu.tw/CTAN/systems/win32/miktex/tm/packages/miktex-zzdb1-2.9.tar.lzma...
2017-07-10 17:36:45,698+0800 FATAL pdflatex - Couldn't connect to server

This is not the entire log file. I just think these are the related messages.

  • 1
    what does it say in C:/Users/username/AppData/Local/MiKTeX/2.9/miktex/log/pdflatex.log ? – Elad Den Jul 10 '17 at 10:16
  • Have you tried installing it from the package manager? Follow the instructions here? – Troy Jul 11 '17 at 1:55
0

I just find it is pretty simply. When I download the ACM template, there is a file called acmart.ins. Just cd to that directory and and open the command line and run:

tex acmart.ins

Then the acmart.cls is created. After that, there may be other packages waiting to install. Just try to compile the .tex file and follow the instructions in the pop-up messages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.