1

I just started using Latex and had a couple of things I am not able to figure out.

  1. I am trying to change the citation style in my thesis format. It is currently something like

    Crowe et al.(Cro96)
    

    But I want it to look like this

    Crowe et al.(1996)
    
  2. Also, my References section is weird. It looks currently like this

    Crowe, C. T. et al. “Two-Phase Turbulent Flows” (1996).
    

    But I would like it to show the names of all the other authors too in the references, obviously(there are three).

  3. I tried using \bibliographystyle{apalike} and \bibliographystyle{plainnat} separately but both give me a similar error

    ! Package biblatex Error: '\bibliographystyle' invalid.See the biblatex package documentation for explanation.Type H <return> for immediate help.... \bibliographystyle{plainnat}
    
    ! Package biblatex Error: '\bibliographystyle' invalid.See the biblatex package documentation for explanation.Type H <return> for immediate help.... \bibliographystyle{apalike}
    

As far as I know, I am using natbib as \RequirePackage[...,backend=bibtex,natbib=true,...]{biblatex}

But I have no idea how to get this to work. I am an absolute beginner to Latex, so I have no idea if the info I have provided is sufficient, so do feel free to ask me for more if required.

6
  • 3
    Welcome to TeX.SE. It does not look at all like you're using the natbib package. Instead, it very much looks like you're using the biblatex package.
    – Mico
    Jul 11, 2017 at 6:39
  • But doesn't natbib=true mean that? Jul 11, 2017 at 6:39
  • 2
    Indeed, the line you showed loads biblatex. But then \bibliographystyle is BibTeX syntax. You will need to show us an MWE so we can see what us going on.
    – moewe
    Jul 11, 2017 at 6:39
  • 1
    No natbib=true only enables biblatex's natbib compatibility mode that allows you to use \citep instead of \parencite etc.
    – moewe
    Jul 11, 2017 at 6:40
  • I will try and make the MWE. Meanwhile, I am using the exact template as here: grad.ncsu.edu/students/etd/etd-templates the thesis template, version 0.6 inside the zip. Do let me know if that will be sufficient, else I will be working on the MWE anyway. Jul 11, 2017 at 6:42

1 Answer 1

1

I take it that you've adapted the file YourName-thesis.tex from the template package for your purposes. In this file, one finds the following passage:

\RequirePackage[
            style=alphabetic,%numeric-comp,%authoryear-comp,%
            sorting=nyt,%ynt                    
            hyperref=true, %    
            firstinits=true,%
            backend=bibtex,
            natbib=true,
            url=false,
            isbn=false,
            maxnames=2, %for et al to be used
            maxalphanames=1, %to avoid printing a + for every et al in the abbreviation
            doi=false]{biblatex}    

The upshot is that (a) the biblatex package is used, (b) the "back-end" program is set to bibtex (the default nowadays is biber), (c) code is loaded to emulate natbib-style citation commands (such as \citet and \citep), and (d) a crude form of the alpha citation call-out style is used. If you don't like these defaults, you have to change one or more of the settings.

5
  • Whoa! Changed the style to authoryear-comp and it works! But I am still having the second issue, where the references are showing et al. Also, they have enabled bibliographystyle plainnat and apalike in the as it is in the tex file, but neither work. What am I doing wrong? Jul 11, 2017 at 8:03
  • If I increase maxnames to 4 or 5, the references correct themselves but now the citation has all the names too, instead of an et al Jul 11, 2017 at 8:05
  • @AyushAgrawal - Do look into what setting the parameter maxcitenames=2 will do for you. By the way, unless you must truncate the number of authors displayed for an entry that features a multitude of authors, I can see no reason for not setting maxnames=999.
    – Mico
    Jul 11, 2017 at 8:08
  • maxcitenames=2 after setting maxnames=999 worked for me. Thanks a lot! Jul 11, 2017 at 8:19
  • @AyushAgrawal - Glad I was able to point you in the right direction.
    – Mico
    Jul 11, 2017 at 8:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .