I'm commuting to using the new biber/biblatex system of referencing. Previously I have been using bibtex as a backend and have tried converting to biber. I'm using MikTeX 2.9 under windows xp sp3.

I compiled my thesis: project name: Thesis_1; backend=biber is set in the options for biblatex.

This runs with the expected reference and shortcut warnings.

Then I run biber Thesis_1 and get:

INFO - This is Biber 0.9.6
INFO - Logfile is 'Thesis_1.blg'
INFO - Reading 'Thesis_1.bcf'
INFO - Found 0 citekeys in bib section 0
INFO - Found 3 citekeys in bib section 1
INFO - Found 132 citekeys in bib section 0
INFO - Processing bib section 0
INFO - Looking for bibtex format file 'References/References1' for section 0
ERROR - Cannot find file 'References/References1'!

You can see that I have my bibliography file inside a folder called References within the project folder and that the bib file is called References1.bib.

The file is there of course.

One possible cause may be a bug related to cross-platform compatibility. The file has been called References/References1, but a backslash should have been used instead for a windows path. Maybe it's not this at all, but it would be nice to have a fix.

  • 7
    It works fine for me. And if I had to guess I would say that your problem has nothing to do with subfolders but that you use \addbibressource and forgot to add the .bib at the end. – Ulrike Fischer Dec 12 '11 at 14:36
  • 4
    Yes, Biber uses a platform agnostic library for file paths etc. so it won't be that. It is probably that you are using \addbibresource but not fully qualifying your file name with .bib as per the biblatex manual. Can you check? – PLK Dec 12 '11 at 20:19
  • 3
    Ulrike and PLK, indeed you are both correct. Adding .bib to the file name resolved the matter, though it was interesting that no problems were caused when using bibtex. I will try and modify the question title and tags so that this might be more helpful to others. If one of you wants to put this as an answer then I will mark it as answered. Else I guess I should close the question. – aghsmith Dec 15 '11 at 12:42
  • 2
    I gave the same answer later so I'll let the first person create an answer. The behaviour of \bibliography{} and \addbibresource is different - the latter required the extension - perhaps you switched commands when you switched backends? – PLK Dec 15 '11 at 14:39
  • I didn't actually. I switched commands when I changed from natbib to biblatex though. I guess it is a case of biblatex and bibtex being happy with either and biber requiring the extension. – aghsmith Dec 15 '11 at 17:09

The question was answered adaquatly, first by Ulrike Fischer and then by PLK in comments above. I'm putting this in so that the question isn't left at an open end.

The issue was that I did not have the .bib extension in the \addbibresource{} command. It was unneeded when using biblatex with bibtex, but was needed when using it with biber.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.