3

How do I increase the line-height of headings in ConTeXT while using grid typesetting without interfering with the alignment of subsequent lines? (Misalignment marked in green).

enter image description here

My code is:

\definefontfeature[default][default][protrusion=quality,expansion=quality,liga=yes,onum=yes]
\setupalign[hanging,tolerant]
\setuppapersize[A5][A5]
\setupinterlinespace[line=16pt]
\setuplayout[
                grid=yes,
               width=fit,
              height=fit,
            location=middle,
            topspace=0.2in,
         bottomspace=0in,
              bottom=0.2in,
           backspace=0.75in,
            cutspace=0.5in,
          leftmargin=0.2in,
         rightmargin=0.75in,
  leftmargindistance=0.1in,
 rightmargindistance=0.1in,
              header=0.20in,
              footer=0.20in,
      headerdistance=0.2in,
      footerdistance=0.2in
]
\setuppagenumbering[
   alternative=doublesided,
      location={footer, right, margin},
         width=1in,
         right={\hfill},
          left={\hfill}
]
\setupheads[indentnext=no]
\setupindenting[yes, small]
\setupmargindata[inmargin][location=right, style=small]
\definepagebreak[mychapterpagebreak][yes,header,right]
\setuphead[chapter][
     page=mychapterpagebreak,
    style=\tfc,
textstyle={\kerncharacters[.5‌​]},
   % If I remove \setuplocalinterlinespace here, I get the alignment right.
   before={\ \blank[2*big]\setuplocalinterlinespace[line=3.2ex]},
    after={\blank[3*big]},
   number=no
]

%\showframe
\showgrid

\starttext
    \chapter[Incididunt reprehenderit cupidatat adipisicing elit qui sit et deserunt sunt amet irure consectetur labore minim commodo]{Incididunt reprehenderit cupidatat adipisicing elit qui sit et deserunt sunt amet irure consectetur labore minim commodo}
    \input khatt-en
\stoptext
2

The \setuplocalinterlinespace[line=3.2ex] seems to leak out from the definition of chapter. Just use the interlinespace option instead. Also you have to start a paragraph before \blank[2*big], otherwise you will also disrupt vertical spacing.

\definefontfeature[default][default][protrusion=quality,expansion=quality,liga=yes,onum=yes]
\setupalign[hanging,tolerant]
\setuppapersize[A5][A5]
\setupinterlinespace[line=16pt]
\setuplayout[
                grid=yes,
               width=fit,
              height=fit,
            location=middle,
            topspace=0.2in,
         bottomspace=0in,
              bottom=0.2in,
           backspace=0.75in,
            cutspace=0.5in,
          leftmargin=0.2in,
         rightmargin=0.75in,
  leftmargindistance=0.1in,
 rightmargindistance=0.1in,
              header=0.20in,
              footer=0.20in,
      headerdistance=0.2in,
      footerdistance=0.2in
]
\setuppagenumbering[
   alternative=doublesided,
      location={footer, right, margin},
         width=1in,
         right={\hfill},
          left={\hfill}
]
\setupheads[indentnext=no]
\setupindenting[yes, small]
\setupmargindata[inmargin][location=right, style=small]
\definepagebreak[mychapterpagebreak][yes,header,right]

\setuphead[chapter][
     page=mychapterpagebreak,
    style=\tfc,
textstyle={\kerncharacters[.5‌​]},
   % If I remove \setuplocalinterlinespace here, I get the alignment right.
   before={\dontleavehmode\blank[2*big]},
   after={\blank[3*big]},
   interlinespace=3.2ex,
   number=no,
]

%\showframe
\showgrid

\starttext
\startchapter
  [title={Incididunt reprehenderit cupidatat adipisicing elit qui sit
      et deserunt sunt amet irure consectetur labore minim commodo}]
  \input khatt-en
\stopchapter
\stoptext

enter image description here

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.