5

After upgrading macOS to Sierra 10.12.5, texshop stopped working: it could open tex files but not typeset. The error message was similar to this:

Library/TeX/texbin /Library/TeX/texbin /Library/TeX/texbin >/Library/TeX/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but >you also need a TeX distribution. Perhaps such a distribution was not installed >or was removed during a system upgrade. If so, go to http://tug.org/MacTeX and >follow the instructions to (re)install MacTeX. A less likely possibility is that >a tool path is incorrectly configured in TeXShop preferences. This can happen if >you are using the macports or fink distributions.

(I can't get the original error message because things got worse...)

After reading various posts, including one here, which had the above quote, I installed the latest mactex2017. Now things are worse: texshop won't open at all.

Error message long. Excerpts:

Path: /Applications/TeX/TeXShop.app/Contents/MacOS/TeXShop Identifier: TeXShop Version: 3.77 (3.77) ... Dyld Error Message: Library not loaded: @rpath/Sparkle.framework/Versions/A/Sparkle Referenced from: /Applications/TeX/TeXShop.app/Contents/MacOS/TeXShop Reason: Incompatible library version: TeXShop requires version 1.6.0 or later, > but Sparkle provides version 1.5.0

Hope that's relevant.

  • Welcome to TeX.SX! Please post some details. Are there any errors or warnings? – TeXnician Jul 14 '17 at 11:51
  • Have edited the post to include error messages. Is there a symbol indicating desperation? – Daniel Nucinkis Jul 14 '17 at 12:28
  • 2
    Solved! Got an email from Richard Koch of TUG (thanks!). Problem is presence of older versions of texshop. Took a while to figure out how to do this, got there thanks to this thread: tex.stackexchange.com/questions/177010/… Also had to manually remove gui from applications folder. – Daniel Nucinkis Jul 14 '17 at 17:37
  • 1
    @DanielNucinkis -- you might make your comment into an answer and accept it. Congratulations for solving your own problem! – Samuel Lelièvre Feb 22 '18 at 23:03
  • 1
    Okay, I worked it out. For the benefit of anyone else who needs it, "manually remove gui" = move TeX folder from applications folder to the trash, then reinstall TeXShop. – Annie Carter Jul 10 '18 at 23:27
1

I had the same issue. For me the following solution works:

sudo rm -rf /Applications/TeXShop.app/
sudo rm -rf /Applications/TeX/TeXShop.app/

Downloading TeXShop from Website

Unzip it and move it to /Applications/TeX/

Maybe it's probably enough to remove one of the two TeXShop app's but I want be sure to have the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.