I'm trying to use \gamma inside the mhchem environment, and it refuses to render the correct glyph. Alpha and beta work, as does Uppercase \Gamma. I have tried this with other fonts e.g. Roboto and the same behaviour occurs.

Is this a bug and is there a workaround? MWE:

\setmainfont{CMU Bright}



The output is the following:

enter image description here

using LuaLatex. With XeTex, a crossed box appears.


Logfile link here: (XeTex) Logfile (LuaLatex)

[! Output of \printchemgreekalphabet]

FINAL EDIT: Shamefully, updating to the newest mactex distribution fixed the problem. Thanks all for your help.

  • 3
    This is what I get: click here for picture
    – egreg
    Jul 14, 2017 at 15:54
  • 1
    Show the log-file. At best from lualatex. Jul 14, 2017 at 16:30
  • 2
    Show the complete log-file. The interesting parts are not in the snippet. Jul 14, 2017 at 16:56
  • 1
    Does \printchemgreekalphabetshow the complete alphabet?
    – mhchem
    Jul 15, 2017 at 5:43
  • 5
    I'm voting to close this question as off-topic because the issue was solved by updating software
    – egreg
    Jul 16, 2017 at 19:46


Browse other questions tagged .