1

Tables are plotting on top of other content within the document that I am creating.

I've tried a series of commands to try to specifically position the tables, and place the tables at the bottom of the page but these do not change the placement.

I've tried:

[h] here, [h!] here, [b] bottom, [!b] bottom, [!bp] bottom page, [htbp], and [htp]

What command should I use to separate the tables and the figures so they display properly? Or possibly a different package that can handle the placement of objects in the floating environment?

This is a 2-column format document. Figure 1 is being plotted on top of Table 1. I believe Table 1 is too long, so it spills into Column 2. Ideally, I would like Table 1 to be positioned to the bottom of the page that it is being referenced on with the document content.

\documentclass[fleqn,usenatbib]{mnras}
\usepackage{graphicx}   % Including figure files
\usepackage{amsmath}    % Advanced maths commands
\usepackage{amssymb}    % Extra maths symbols
\usepackage{dblfloatfix}

% Figure_1
\begin{figure} 
    % To include a figure from a file named example.*
    % Allowable file formats are eps or ps if compiling using latex
    % or pdf, png, jpg if compiling using pdflatex
    \includegraphics[width=\columnwidth]{Figure_1.png}
    \caption{Absolute magnitude vs. semimajor axis for (1839) Ragazza, (2373) Immo, (2386) Nikonov, (2521) Heidi and (3860) Plovdiv. Asteroids belonging to the Gefion family from Nesvorny (2012) are depicted as gray circles. As a reference, asteroid (1272) Gefion is also included and depicted with a black circle. The location of the 5:2 mean motion resonance is represented by a vertical dashed line.}
    \label{fig:example_figure}
\end{figure}

% Table 1
\begin{table}
    \centering
    \caption{Observational circumstances for the asteroids observed for this campaign.}
    \label{tab:example_table}
    \begin{tabular}{|lccccc|} % six columns, alignment for each
        \hline
        Asteroid Target & Observation Date UTC (GMT) & Solar Analog Star & Airmass & Phase Angle (degrees) & Heliocentric distance (AU)\\
        \hline
        (1839) Ragazza & 2014/11/24 17:00:00 & SAO 93936 & 1.031 & 21.6 & 2.551\\
        (2373) Immo & 2014/09/23 23:00:00 & SAO 93936 & 1.345 & 23.6 & 2.505\\
        (2386) Nikonov & 2015/01/17 23:00:00 & SAO 120107 & 1.087 & 17.0 & 3.162\\
        (2521) Heidi & 2014/09/04 10:00:00 & SAO 75021 & 1.011 & 15.6 & 3.013\\
        (3860) Plovdiv & 2015/09/22 17:00:00 & SAO 93936 & 1.322 & 22.8 & 2.384\\
        \hline
    \end{tabular}
\end{table}

\end{document}
  • 2
    Welcome to TeX.SX! Please help us help you and add a minimal working example (MWE) that illustrates your problem. Reproducing the problem and finding out what the issue is will be much easier when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – samcarter_is_at_topanswers.xyz Jul 14 '17 at 19:11
  • 1
    If I've understood correctly, the behaviour you're describing is not default and is not caused by anything in the code you've shared. So, right now, we can only say that the problem is in the code you haven't shared, which may or may not be helpful. – cfr Jul 14 '17 at 19:45
  • The series of commands that I found for adjustment/placement of the floating table did not move or adjust in any way. Ideally, I'd like the table to be displayed at the top or bottom of the page that it is referenced on. The problem I think lies in the floating environment that the table possess. I need to find a way to to adjust the table to be positioned either at the top or bottom of the page that it is referenced on. The MNRAS LaTeX template that I am using does indeed have a 2-column format. – Sonny_McGraw Jul 14 '17 at 20:05
  • When the table is printed, it must be printing in Column 1, however the content in Column 2 prints right on top of the over-sized table from Column 1. Refined question would be: How to handle a wide table placement within a two column format? – Sonny_McGraw Jul 14 '17 at 20:15
  • 1
    thank you for clarifying the question, your initial version didn't even mention that it was two column, or that you were getting over-full box messages that the tables were wider than the column, so was not answerable. – David Carlisle Jul 14 '17 at 21:27
1

From the mnras user guide:

The LATEX float placement commands [htbp] are intentionally disabled. Layout of figures and tables will be adjusted by the publisher during the production process, so authors should not concern themselves with placement to avoid disappointment and wasted effort.

Simply place the LATEX code close to where the figure or table is first mentioned in the text and leave exact placement to the publishers. By default a figure or table will occupy one column of the page. To produce a wider version which covers both columns, use the figure* or table* environment.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.