7

My code is this simple:

\documentclass[12pt,a4paper]{report}
\usepackage[a-2u]{pdfx}
\usepackage[british,czech]{babel}

\begin{document}
    Blah
\end{document}

And yet it causes me troubles with

! No color profile found to use for RGB screen colors..
\reserved@a ...ound to use for RGB screen colors.}
l.742 }
%
This error message was generated by an \errmessage
command, so I can't give any explicit help.
Pretend that you're Hercule Poirot: Examine all clues,
and deduce the truth by order and method.

I use pdfLaTeX (Texmaker).

Is that a problem with packages? I do not understand LaTeX much, I had everything working, but now I have to switch to pdfx and it causes me troubles.

Apparently it is caused by this part of pdfx.sty

\IfFileExists{"\pdfx@rgb@profile"}{%
  \immediate\pdfobj stream attr{/N 3^^J/Alternate/DeviceRGB} file{"\pdfx@rgb@profile"}%
  \edef\OBJ@RGB{\the\pdflastobj}%
  \pdfcatalog{%
   /ViewerPreferences <</DisplayDocTitle true >>
   /OutputIntents [ <<
   /Type /OutputIntent
   \ifpdfx@e
    /S/ISO_PDFE1
   \else
    /S/GTS_PDFA1
   \fi
   /OutputConditionIdentifier (\pdfx@rgb@identifier)%
   /DestOutputProfile \OBJ@RGB\space 0 R
   /Info(\pdfx@rgb@info)
   /RegistryName(\pdfx@rgb@registry)
  >>
 ]}%
 }{%
  \errmessage{No color profile found to use for RGB screen colors.}%
 }%

Any idea how do I create the right file?

4
  • 1
    Apart from the error for the missing image file, I get nothing else.
    – egreg
    Jul 15, 2017 at 17:46
  • hm... it must be the packages than
    – Elza
    Jul 15, 2017 at 17:49
  • I get the same even without the image..
    – Elza
    Jul 15, 2017 at 17:58
  • 1
    show the log file you get for the above test, my log shows the profile <<sRGB_IEC61966-2-1_black_scaled.icc>> being used where that file is kpsewhich sRGB_IEC61966-2-1_black_scaled.icc /usr/local/texlive/2017/texmf-dist/tex/latex/pdfx/sRGB_IEC61966-2-1_black_scaled.icc Jul 15, 2017 at 19:35

5 Answers 5

9

I had a hard time getting this to work on my system. I ended up trying in latest Ubuntu, which did obviously not yet have the fixes. After this I installed Debian testing as per https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=877167 the problem was supposed to be fixed with their latest texlive packages. To my surprise, it did not work initially. Then I realized that I had to enable the Debian non-free repos in /apt/sources.list:

deb http://ftp.fi.debian.org/debian/ buster main contrib non-free
deb-src http://ftp.fi.debian.org/debian/ buster main contrib non-free

and install the actual ICC profiles manually:

apt-get install icc-profiles

After this, the typesetting started to work with texlive-2017.20171004-1 on my Debian. If I remove the icc-profiles package, the typesetting fails again (of course).

1
  • Now you can install icc-profiles also with Ubuntu.
    – tillmo
    Jul 1, 2021 at 7:03
4

I get the same error on my Ubuntu system. There are many distributions with the old / broken pdfx package. You can download a new version from https://www.ctan.org/pkg/pdfx or use sharelatex.com which seems to work effortlessly.

3
  • The problem seems to be that Debian/Ubuntu does not package these files as part of TeXLive. They are available in the icc-profiles package; however, the TeXLive packages do not depend on this package, nor are the files made known to kpathsea, so it can't find them even if they are installed. I'm looking into this, and will report a suitable bug. Oct 23, 2017 at 13:52
  • Part of the problem is that the default profile used by pdfx is not free software (the icc-profiles package is non-free), so can't be depended on by the TeXLive packages. Oct 23, 2017 at 14:25
  • In fact, this bug has recently been fixed in Debian, version 2017.20171004-1 of the texlive packages. See bugs.debian.org/cgi-bin/bugreport.cgi?bug=877167 Oct 23, 2017 at 14:29
2

Upgrade to texlive-2017.20171004-1 or later Debian/Ubuntu packages, where this bug is fixed. The bug is https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=877167

(If updating is not an option, then you can install pdfx from CTAN or symlink the required .icc files into your local or per-user texmf tree.)

1
  • 1
    I have made a request for the Ubuntu 16.04 backports of TeXLive 2017 to be updated. Oct 23, 2017 at 14:37
1

I had the same problem on Archlinux with the template for my thesis. Just installing the adobe icc profiles from aur or placing the icc file into the pdfx directory did not help me. My solution was to place the icc file (sRGB_IEC61966-2-1_black_scaled.icc) directly into the directory of my master .tex file.

After this I also had a Problem with undefined colors which I fixed by adding 'dvipsnames' to the documentclass.

0

According to an exchange on the tex-live mailing list, it looks like an .icc file that used to be included in TeXLive was removed for licensing concerns. However, in a follow-up, the colorprofiles packages was announced. Installing the colorprofiles packaged (e.g. tlmgr install colorprofiles) solved the issue for me without needing to go "non-free".

Additionally, you can explicitly require the package as follows (this is especially convenient for situations where packages are auto-installed):

\documentclass[12pt,a4paper]{report}
\RequirePackage{colorprofiles}
\usepackage[a-1b]{pdfx}
\usepackage[british,czech]{babel}

\begin{document}
    Blah
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .