0
\documentclass{UnimasThesis}
\usepackage{graphicx}
\usepackage[labelfont=bf]{caption}
\captionsetup{labelfont=bf}
\usepackage{pdflscape}
\usepackage{adjustbox}
\usepackage{dcolumn}
\usepackage{booktabs}
\usepackage{amsmath}
\usepackage{cases}
\usepackage[os=win]{menukeys}
\usepackage[paper=a4paper]{geometry}
\usepackage{multirow}
%\usepackage{enumerate}


\usepackage{listings}
\lstset{language=[LaTeX]TeX,columns=fullflexible,
basicstyle=\ttfamily,texcsstyle=*\bfseries\color{NavyBlue},
commentstyle=\itshape\color{PaleVioletRed4},
frame=single,framesep=6pt,
framexleftmargin=6pt,framexrightmargin=6pt,
xleftmargin=12pt,xrightmargin=12pt,
breaklines=true,breakatwhitespace=true}


\title{AUTOMATIC SEGMENTATION OF CARDIAC MAGNETIC RESONANCE IMAGES FOR OEDEMA ASSESSMENT}
\author{Amajd Khan}
\faculty{Faculty of Computer Science and Information Technology }
\facultyColour{6c7a8c} %% 6-digit RGB hexadecimal code 
\submissionyear{2017}
\degreetype{Doctor of Philosophy\\(Computer Science)}

% If using APA bibliography style

\usepackage[natbibapa]{apacite}
\bibliographystyle{plainnat}
%\usepackage{natbib}
%\bibliographystyle{apalike}

\makeatother

\begin{document}
\maketitle

\frontmatter



\mainmatter
% Each chapter from a separate file
\input{chap1-Introduction}

% references are listed in refs.bib
\bibliography{refs}

\end{document}

%%%refrence

@article{rao:2014,
    title={Causes of Sudden Cardiac Death on Autopsy Findings; a Four-Year Report},
    author={Rao, Dinesh., and Sood, Divya., and Pathak, P., and Dongre, Sudhir, D},
    journal={Journal  of Emergency-An Academic Emergency Medicine},
    volume={2},
    number={1},
    pages={12-17},
    year={2014}
}

%%%i use the chapter 1 file (Example

this is my citation Rao et al.,(2014). (need to show like this

32
  • 2
    Please provide compilable code! Read the given links carefully. You can edit your question and add a MWEB(see link above). – Bobyandbob Jul 17 '17 at 11:26
  • 1
    @amjad Just to understand your question, why not use the \usepackage{natbib} \bibliographystyle{apalike} which is currently commented in your code? This will give you Rao et al. (2014) in the text. – samcarter_is_at_topanswers.xyz Jul 17 '17 at 16:53
  • 2
    @amjad Sorry, but email this is not how this site works. Show the output/error messages of my short example in your question and I will try to help you but private communication is not part of this site. – samcarter_is_at_topanswers.xyz Jul 17 '17 at 17:12
  • 1
    As annoying as it is, it is an important large debugging skil. You need to make a doc, that shows your problem. For instance you have no citations in your mwe, so others testing your mwe, would have to add that. You load many packages in the preamble the t are not relevant to bibliographies, remove them to reduce the mwe. Perhaps even test if the problem exist if you switch to the book class, again reducing the mwe to something others have direct access to. You don't need frontmatter mainmatter and maketitle. – daleif Jul 28 '17 at 10:19
  • 1
    @amjad So if it is solved, why arent't the answers to both questions not upvoted by you? Why did you ask the same question two times? This is not how this site works. We are not a do it for me for free help desk, we invest our personal time to help people like you. – Johannes_B Jul 30 '17 at 6:25
6

The apacite package implements a proper APA style bibliography which requires full citations on first mention for author lists up to 7 authors. Since you are loading the package with the [natbibapa] option, you can specify in the preamble a list of bib keys that you want to appear as "short citations". So schematically you can do the following:

\documentclass{article}
\usepackage[natbibapa]{apacite}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@article{Chandra:81,
    author = {Ashok K. Chandra and Dexter C. Kozen and Larry J. Stockmeyer},
    year = "1981",
    title = {Alternation},
    journal = {Journal of the Association for Computing Machinery},
    volume = "28",
    number = "1",
    pages = "114--133"
}


@article{rao:2014,
    title={Causes of Sudden Cardiac Death on Autopsy Findings; a Four-Year Report},
    author={Rao, Dinesh and Sood, Divya and Pathak, P. and Dongre, Sudhir, D},
    journal={Journal  of Emergency-An Academic Emergency Medicine},
    volume={2},
    number={1},
    pages={12-17},
    year={2014}
}
\end{filecontents*}
\shortcites{rao:2014} % list all the entries you want to have short cites
\begin{document}
\citet{Chandra:81} will show up long on first mention and short in subsequent mention: \citet{Chandra:81} but \citet{rao:2014} will show up short even on first mention because it was listed in the \verb|\shortcites| command.

\bibliographystyle{apacite}
\bibliography{\jobname}

\end{document}

output of code

3
  • Do you have a solution for the situation in which I want to force the short cite in some part of the paper (e.g., in a table), but have the proper full apacite citation in others (e.g, in-text)? – jmb Oct 22 '20 at 10:55
  • 1
    @jmb if you're using the natbibapa option, there's not a direct way to do this. If you're using the apaciteclassic option (which has a different set of citation commands) you can use \shortcite or related commands. See texdoc.org/pkg/apacite for details. You might be able to do this with the natbib \citealias command. See texdoc.org/pkg/natbib for details. – Alan Munn Oct 22 '20 at 18:09
  • 1
    The solution with \citealias is a bit inelegant, but it works. Thanks a lot! – jmb Oct 23 '20 at 19:10
2

Because you've loaded the apacite citation management package, you're getting exactly the behavior it's been programmed to do: It generates a citation call-out with a list of all authors (up to 7, that is) the first time a given entry is cited, and it truncates the list (to first-author et al) from the second time on.

If you do not want this behavior, don't load the apacite package. Instead -- especially in view of the fact that you seem to like the plainnat bibliography style -- you should be loading the natbib package. And, of course, you absolutely must purge the surplus commas from the entry's author field.

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@article{rao:2014,
    title   = {Causes of Sudden Cardiac Death on Autopsy Findings; a Four-Year Report},
    author  = {Rao, Dinesh and Sood, Divya and Pathak, P. and Dongre, Sudhir.D},
    journal = {Emergency},
    volume  = {2},
    number  = {1},
    pages   = {12-17},
    year    = {2014}
}
\end{filecontents}

\documentclass{article}
\usepackage[paper=a4paper]{geometry}
\usepackage[authoryear,round]{natbib}
\bibliographystyle{plainnat}

\begin{document}
\citet{rao:2014}, \citep{rao:2014}
\bibliography{mybib}
\end{document}
-1

The best way you can manually copy the references and paste into \shortcites, e.g. \shortcites{rao:2014}

1
  • How does your answer differ from (or add to) the one by Alan Munn? – Mico Apr 23 '18 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.