3

I'm not completely new to Latex, but using it again after about 10 years of abstinence. Using TexStudio on a mac and IntelliJ on Ubuntu trying to write my thesis. I'm using a predefined template from the university with some manually installed addons (eg. code syntax highlighter minted). So far I've written about 8 pages.

My problem is, that pdflatex only renders the first six pages. I have separated all the chapters in separate files and when commenting out one or another include, the remaining chapters are rendered with no problems. Until page six... I can see warnings about missing fonts (eg for some bullet point on page 7) and how defaults are substituted, so TexStudio does seem to compile the complete document. I cannot, however find any useful information about what might go wrong. So, I was hoping to find a setting inside TexStudio. Since I get the same result when building directly in a terminal window, there must some other reason.

Only thing is, I don't really know where to start looking. Any ideas?

cheers, Lugi

edit answers/comments

--> Just found out, that when inserting a '\lispum' anywhere, everything is rendered as expected. *confused*

thank you for the answers so far. I've checked for what you guy suggested:

  • neither \includeonly, nor an early \end{document} are present
  • leaflet.cls is not being used
  • as mentioned, the log file shows a few warnings, but nothing what would point me into the right direction. There is a an underfull hbox warning for a table, though. Problem persists if I comment out said table.

Files can be found on pastebin:

  • 2
    You have probably made a serious mistake somewhere in page 6 that causes pdfLaTeX to stop trying to render the rest. If not, provide a minimal example in your post. – st.vit Jul 17 '17 at 19:38
  • 4
    usual reasons are you have \end{document} in whichever file is typeset last, or you have \includeonly specifying just the first section. – David Carlisle Jul 17 '17 at 19:53
  • 2
    Unlikely, but possible: If the template is using leaflet.cls, then the 6 pages is a feature :) – knut Jul 17 '17 at 20:00
  • The bug must be in the file that if not included causes latex to produce the remainder of the output. – JPi Jul 18 '17 at 10:43
  • Exceedingly unlikely: \include is redefined in one of the included files.... ;-) – JPi Jul 18 '17 at 10:44
2

The code shown (which would be better in the question than as an external link) doesn't give many clues but, for example, the log shows

 (./kapitel/problemstellung.tex
Kapitel 2.
Package babel Info: Redefining ngerman shorthand "|
(babel)             in language  on input line 1.
Package babel Info: Redefining ngerman shorthand "~
(babel)             in language  on input line 1.
LaTeX Font Info:    Font shape `T1/aess/m/it' in size <10> not available
(Font)              Font shape `T1/aess/m/sl' tried instead on input line 4.
)

So chapter 2 is input, which discounts the earlier guesses of \includeonly{chapter1} or chapter 1 having a spurious \end{docuemnt}

But it also shows that this file problemstellung.tex just redefines " most likely by switching to german language, selects italic on line 4, and then the file ends without typesetting any text and the processing moves to chapter 3, which does essentially the same thing again.

so, if the file kapitel/problemstellung.tex does have some text then probably you should show an example document using this file (if the actual words are not to be public, replace every word in the text by foobar, that does not matter so long as it reproduces the problem).

  • Thanks for the reply and sorry for using pastebin. Thought, it was a bit much to paste directly inside the question. I found this about the redefines: tex.stackexchange.com/questions/193025/… so this should not be a problem. The 'problemstellung.tex' basically contains plain text with some '\emph{text}'. – Beat Luginbühl Jul 19 '17 at 12:35
1

I've found the culprit:

This document is "just" the project application for the thesis. Therefore I inserted the following two lines to prevent Latex from inserting page breaks before every chapter:

\renewcommand{\cleardoublepage}{} \renewcommand{\clearpage}{}

After removing those lines, all the pages get rendered. Looks like I have to find another solution... Why everything gets rendered "correctly" when combining these two lines with a \lipsum remains a mystery.

Every comment here is very much appreciated. Thank you.

Cheers, Lugi

  • 2
    Your definition is equivalent to removing the steering wheel, clutch and motor from your car and wonder why it doesn't work properly. – Johannes_B Jul 19 '17 at 14:16
  • If you apparently do not want chapters (as it makes no sense if they do not start on new pages), why do you not switch to scrartcl and use \section instead of \chapter as topmost sectioning level. It is even more curious that you have openright in your KOMA options. So you are having a \cleardoublepage instead of \clearpage after chapters. Why not use open=any? – Manuel Weinkauf Jul 19 '17 at 15:50
  • @ManuelWeinkauf I will try that. I didn't create the template myself, instead I used the one I got from the university. I don't want to start a new page after every chapter/section in the application. The actual thesis, however, is another story. As mentioned in my very first post, I haven't used Latex in a while. Still more than Word/LibreOffice, though ;-) – Beat Luginbühl Jul 20 '17 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.