1

I have made a bibliography with bibtex, however I cannot manage to get the style to change to alpha style.

I have read several answers such as Bibliography not changing according to style but nothing is working.

I've tried recompiling with latexpdf, latexpdf, bibtex, latexpdf; I've tried deleting all my auxiliary files; and I've tried putting my bib code in different places and orders, but nothing seems to work.

My document (simplified) looks something like this.

\documentclass[12pt]{article}
\usepackage{amsfonts}
\usepackage{amsmath}
\usepackage{tikz-cd}
\usepackage{amsthm}
\usepackage[hidelinks]{hyperref}
\setlength{\parindent}{0pt}
\usepackage{fullpage}
\usepackage{amsrefs}
\usepackage{stmaryrd }
\usepackage{ amssymb }
\usepackage{amsthm}
\usepackage{enumitem}
\usepackage{thmtools}
\usepackage{thm-restate}


\begin{document}




Example citations are \cite{CLS} and \cite{Herbst}. 

\bibliography{ThesisBib}{}
\bibliographystyle{alpha}
\end{document}

And my .bib file looks like this

    @Article{Herbst,
        Author = {Patrick {Clarke} and Josh {Guffin}},
        Title = {{On the existence of affine Landau-Ginzburg phases in gauged linear sigma models.}},
        FJournal = {{Advances in Theoretical and Mathematical Physics}},
        Journal = {{Adv. Theor. Math. Phys.}},
        ISSN = {1095-0761; 1095-0753/e},
        Volume = {19},
        Number = {4},
        Pages = {725--745},
        Year = {2015},
        Publisher = {International Press of Boston, Somerville, MA},
        Language = {English},
        DOI = {10.4310/ATMP.2015.v19.n4.a1},
        MSC2010 = {81T13 35Q56},
        Zbl = {1338.81285}
    }

@Book{CLS,
Author = {David A. {Cox} and John B. {Little} and Henry K. {Schenck}},
Title = {{Toric varieties.}},
ISBN = {978-0-8218-4819-7/hbk},
Pages = {xxiv + 841},
Year = {2011},
Publisher = {Providence, RI: American Mathematical Society (AMS)},
Language = {English},
MSC2010 = {14-01 14M25 14C17 14C15},
Zbl = {1223.14001}
}

The bibliography is showing up in my document; however it is showing up in plain style.

Any help fixing this would be much appreciated.

  • I tried updating Miktex and unfortunately it didn't fix anything. Is there anything else I should be updating? – CEH Jul 18 '17 at 0:06
1

Your "problem" is with the amsrefspackage. This package uses its own bibstyles. You can observe that if you comment \usepackage{amsrefs} works with alpha style.

When you load amsrefs package it uses by default the amsrn.bst style defined in the package.

If you still want to use the amsrefs package with alpha style you must load the package with the alphabetic option (or shortalphabetic option)

\usepackage[alphabetic]{amsrefs}

or

\usepackage[shortalphabetic]{amsrefs}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.