0

I have a strange problem with ligatures at the bibliography using the combination of unicode-math and windows cleartype fonts(Calibri & Consola).

MWE:

\documentclass{article} 
\usepackage{fontspec}
\setmainfont{Calibri}
\setmonofont{Consola}
\usepackage{unicode-math}
\begin{document} 
Seattle if dictionary fifty \\
Seattle if dictionary fifty \texttt{Consolafont}
\end{document} 

Using lualatex, this leads to the following corrupt 'Seattle'-ligature: enter image description here

The problem exists only at this combination of consola/calibri font and unicode-math. In annother document, the problem occurs also at the fifty, but not here ?!

Does somebody has an idea how to solve this issue? And is it a unicode-math problem, a lualatex problem, a font problem or something else?

  • Just for fun, does this also happen if you write Seattle in the text? (because then your MWE does not need biblatex and can be simplified a lot. (I cannot test as I don't have access to the fonts) – daleif Jul 20 '17 at 14:12
  • No, in textmode everything is correct. I think the problem is the mixture of the different fonts – sistlind Jul 20 '17 at 14:37
  • Strange, then ought to tag it with biblatex as well. Is there something funny in the .bbl file? – daleif Jul 20 '17 at 14:48
  • Oh sorry, my mistake, i seldomly use monospace font within regular text... The MWE can defined short, see the update above – sistlind Jul 20 '17 at 15:24
  • Fails for me with lualatex with the default fontloader but works with a newer, local one. – Ulrike Fischer Jul 20 '17 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.