1

First of all, I should say that this is my first question here, so please be patient if I lack initial detail and thanks in advance for any help.

I am compiling a document with pdflatex from a TeXLive 2013 version. I need to embed all fonts, or otherwise the uploaded document is returned as non-compliant.

I have configured

pdftexDownloadBase14 true

in udpmap.cfg, and I have tried to follow these steps to create a full font embedding map, with no success. The output of pdffonts is

name                   type       encoding         emb sub uni object ID
---------------------- ---------- ---------------- --- --- --- ---------
Helvetica              Type 1     Standard         no  no  no      86  0
Helvetica              Type 1     Standard         no  no  no      89  0
Times New Roman,Bold   TrueType   WinAnsi          no  no  no     271  0
Times New Roman,Bold   TrueType   WinAnsi          no  no  no     277  0
Helvetica              Type 1     Standard         no  no  no     296  0
Helvetica              Type 1     Standard         no  no  no     299  0

and the font embedding window in evince outputs the following:

Font embedding errors as per Evince

Is there any way I can make sure that all fonts are embedded?

  • Did you check tex.stackexchange.com/questions/10391/… If you did not, go ahead and check it to see if that solves your problem. The search box is your friend :) – A Feldman Jul 20 '17 at 17:02
  • Welcome! Otherwise, can you provide a complete but minimal document which reproduces the issue? We need code we can compile to try to reproduce the problem. Why are you using TeX Live 2013? (This shouldn't matter - just seems old.) Which updmap.cfg did you edit? Did you run updmap-sys afterwards? Have you ever run updmap or getnonfreefonts (i.e. without the -sys)? – cfr Jul 20 '17 at 19:05
  • @AFeldman sure, I did. It worked in the past, so I am not really sure why it does not for this specific document. – Paolo-2017 Jul 21 '17 at 8:26
  • @cfr, I am trying your steps, will let you know if it works asap. – Paolo-2017 Jul 21 '17 at 8:34
  • @cfr, as a follow-up, unfortunately those steps do not help. Working on an MWE, will be back soon. – Paolo-2017 Jul 22 '17 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.