2

I use WinEdt 9.1 with both biber (version 2.7) and bibtex. When I call biber, I want to pass the --nostdmacros argument to it. How may I do this?

Ordinarily, I would just go to Execution Modes > Console Applications, select "BibTeX" in the "Accessories" box, and add my argument to the "Switches" field. But I cannot do that in this case: I need to use WinEdt for bibtex as well, and bibtex doesn't recognize the --nostdmacros argument. I need to find a different way to pass this argument to biber.

Here is the relevant part of my MainMenu.ini:

ITEM="Biber"
  CAPTION="Biber"
  IMAGE="Biber"
  MACRO=`Assign("Old-BibTeX-Executable","%$('BibTeX-Executable');");`+
        `Assign("BibTeX-Executable","biber.exe");`+
        `Exe('%b\Exec\TeX\BibTeX.edt');`+
        `Assign("BibTeX-Executable","%$('Old-BibTeX-Executable');");`+
        `Release("Old-BibTeX-Executable");`
  SHORTCUT="49218::Ctrl+Alt+B"
  REQ_FILTER=:%O\%N.bcf*"%!M=TeX"|"%!M=TeX:STY"|"%!M=TeX:AUX"

Is there a way to change this entry so that I can pass the argument to biber?

3

Yes, it is possible. Note, however, that --nostdmodes seems not to be a valid biber option. Perhaps did you mean --nostdmacros?

Anyway, choose the right option and substitute it in the following lines which have to replace the original lines:

  ITEM="Biber"
    CAPTION="Biber"
    IMAGE="Biber"
    MACRO=`Assign("Old-BibTeX-Executable","%$('BibTeX-Executable');");`+
          `Assign("BibTeX-Executable","biber.exe");`+
          `Assign("Old-BibTeX-Switches","%$('BibTeX-Switches');");`+
          `Assign("BibTeX-Switches","--nostdmacros");`+
          `Exe('%b\Exec\TeX\BibTeX.edt');`+
          `Assign("BibTeX-Executable","%$('Old-BibTeX-Executable');");`+
          `Assign("BibTeX-Switches","%$('Old-BibTeX-Switches');");`+
          `Release("Old-BibTeX-Executable");`+
          `Release("Old-BibTeX-Switches");`
    SHORTCUT="49218::Ctrl+Alt+B"
    REQ_FILTER=:%O\%N.bcf*"%!M=TeX"|"%!M=TeX:STY"|"%!M=TeX:AUX"

Remember to reload MainMenu.ini through the shortcut Shift+Ctrl+F9.

  • Thank you. This worked perfectly. And --nostdmacros is indeed what I meant -- I edited the original post accordingly. – user697473 Jul 22 '17 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.