1

I get: Reason: Incompatible library version: TeXShop requires version 1.6.0 or later, but Sparkle provides version 1.5.0

I am aware of the answers to similar problems:

and did delete older versions of TeXShop as well as runtime directories.

However the problem persists.

8
  • 3
    What version of TeXShop are you using? Are you sure you really removed all old versions of TeXShop since that message makes it appear you have an old version still around? Have you tried to reboot to clear out any caches in memory? Jul 24, 2017 at 0:44
  • Hello Herb, As in questions/177010, I wrote and got: cd /usr/local/texlive MINEDI722110:texlive carstennielsen$ ls 2017 texmf-local MINEDI722110:texlive carstennielsen$ I checked texmf-local and it was updated the same day I installed the new version of Texshop so I suppose I should not delete it? Thanks for your help!
    – Carsten
    Jul 24, 2017 at 20:35
  • What is MINED... is that part of your prompt? I'm not sure I understand what you did. What version of TeXShop are you trying to use? Did you really remove /usr/local/texlive/2017? Jul 24, 2017 at 21:14
  • Let me add, what OS version sis you update from? And finally, do you lots of very old software around tha used Sparkle to update itself but hasn't been updated in a long time? Jul 25, 2017 at 0:51
  • Thanks again, Herb for your interest. Earlier I removed texlive/2010 but I have retained the newly installed texlive/2017. "MINEDI722110:texlive carstennielsen$" is the response when I write "cd /usr/local/texlive" in the terminal. Then I write "ls" and get "2017 texmf-local" which I guess is the list of items in texlive (I am not well versed in programming fundamentals). I seek to use the newest version of texlive. A technician updated from the 2010 OS to Sierra and it is very possible that I have old software from my back-up (would removing Texworks help?) But how to find it? Thanks!
    – Carsten
    Jul 25, 2017 at 8:45

1 Answer 1

1

I had this same problem and solved it by following a combination of Herb's advice:

  1. I searched for TeXShop using Spotlight-- the computer found several versions that were not showing up in the finder
  2. I trashed all of the versions I could find
  3. I rebooted and reinstalled

Thanks, Herb!

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .