6

I am trying to include some resources from Russian and other languages in my bibliography. With the MWE I have here everything is fine, but it fails to print the journal name correctly.

The ideal case is that I do not have to define language and hyphenation as the desired language for each resource.

But even trying to include Russian language option in my bibitem, it does not seem to work and I get an error.

Is there any way to fix it in a not too complicated way?

\documentclass{article} 
\usepackage[T1,T2A]{fontenc} 
\usepackage[utf8]{inputenc}
\usepackage[russian,german,english]{babel}
\usepackage{csquotes}
\usepackage[style=authoryear-icomp,bibencoding=utf8]{biblatex}
\bibliography{test.bib}

\begin{document}
some text \cite{russian}

\printbibliography
\end{document}

My test.bib file content:

  @article{russian,
  title={Курс общей физики, том III. Оптика, атом ная физика, физика атомного ядра и элементарных частиц},
  author={Савельев, ИВ},
  journal={ Курс общей физики, том III.},
  year={1973},  
}

enter image description here

I put a part of the title into journal section name to show what I get correctly in the title is printed in an awkward way in journal title part.

  • 7
    Mhhh, but isn't that they way Cyrillic looks in italics? – moewe Jul 24 '17 at 10:34
  • 9
    Nope, that is correct, Russian italics looks more like handwriting, which looks a bit particular for us non-Russians. – moewe Jul 24 '17 at 10:37
  • 4
  • 3
    If you don't want italic, you could try with \slshape – user36296 Jul 24 '17 at 10:39
  • 2
    I can only add that the word "атомная" ("nuclear") somehow got split into two ("атом ная"), which will be understood but is still a typo. – Igor Soloydenko Jul 24 '17 at 15:25
14

The output you get is correct. The journal name is set in italics. Russian italics look more like the handwriting, where some letters have shapes differing from their upright shapes. See Why does italic 'т' look like 'm' over at Russian.SX, Wikipedia on Cyrillic script and Russian cursive, Russian alphabet.

  • 1
    @egreg The default setting is language=autobib, so only the bibliography language is switched according to langid. That causes troubles because the citation label also wants Cyrillic. We need language=auto to switch both bibliography and citations to other*. – moewe Jul 24 '17 at 11:00
  • I realized it, so I removed my comment. What's probably needed here is that the reference uses a transcription: if the main language is English, a Cyrillic author name in the text would be quite strange. – egreg Jul 24 '17 at 12:37
  • @egreg Mhhh, maybe. Unfortunately, development of the multiscript version of biblatex, that would have enabled this and probably much more, seems to have stalled. – moewe Jul 24 '17 at 12:50
  • and How can I fix this issue? – Prelude Jul 24 '17 at 19:14
  • @Prelude Sorry, what issue? If you use \usepackage[T2A,T1]{fontenc} you will need to mark Russian entries as Russian withlangid = {russian} (you can also give language = {russian} if you want) and use language=auto, autolang=other*. – moewe Jul 25 '17 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.