5

I ran an update on texlive 2017 (via tlmgr) and I got an error for the acro package that I have not experienced before.

I have provided a MWE:

\documentclass{article}

\usepackage{acro}
\DeclareAcronym{RES}{
    short = RES ,
    long = Renewable Energy Sources ,
}
\listfiles
\begin{document}
    \ac{RES}
\end{document}

This is my output for \listfiles

*File List*
 article.cls    2014/09/29 v1.4h Standard LaTeX document class
  size10.clo    2014/09/29 v1.4h Standard LaTeX file (size option)
    acro.sty    2017/06/21 v2.7b Typeset Acronyms
   expl3.sty    2017/07/19 L3 programming layer (loader) 
expl3-code.tex    2017/07/19 L3 programming layer 
l3pdfmode.def    2017/03/18 v L3 Experimental driver: PDF mode
  xparse.sty    2017/07/19 L3 Experimental document command parser
l3keys2e.sty    2017/07/19 LaTeX2e option processing using LaTeX3 keys
xtemplate.sty    2017/07/19 L3 Experimental prototype document functions
etoolbox.sty    2017/01/02 v2.4 e-TeX tools for LaTeX (JAW)
zref-abspage.sty    2016/05/21 v2.26 Module abspage for zref (HO)
zref-base.sty    2016/05/21 v2.26 Module base for zref (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
pdftexcmds.sty    2017/03/19 v0.25 Utility functions of pdfTeX for LuaTeX (HO)
   ifpdf.sty    2017/03/15 v3.2 Provides the ifpdf switch
 auxhook.sty    2016/05/16 v1.4 Hooks for auxiliary files (HO)
atbegshi.sty    2016/06/09 v1.18 At begin shipout hook (HO)
translations.sty    2017/05/16 v1.6 internationalization of LaTeX2e packages (C
N)
scrlfile.sty    2017/04/13 v3.23 KOMA-Script package (loading files)
translations-basic-dictionary-english.trsl    (english translation file `transl
ations-basic-dictionary')
 ***********

and this is the error in the log-file:

! Missing number, treated as zero.
<to be read again> 
                   \l__acro_RES_long-plural_set_bool 
l.7 }

A number should have been here; I inserted `0'.
(If you can't figure out why I needed to see a number,
look up `weird error' in the index to The TeXbook.)

Could it be linked to the packages acro requires? They seem to be updated.

  • 2
    Somehow \l__acro_RES_long-plural_set_bool is undefined and tested using \bool_if:NTF which expects either a boolean equal to either true or false (I tweaked \bool_if:NTF a tiny bit and it used to detect arbitrary control sequences as false). The acro code (or your use of it, I didn't check) was wrong all along and just worked by accident. – Bruno Le Floch Jul 24 '17 at 13:22
  • 3
    Looks like a bug. Do you mind reporting it here: bitbucket.org/cgnieder/acro/issues – clemens Jul 24 '17 at 13:51
  • 1
    Thank you for the quick response. I have created an issue: bitbucket.org/cgnieder/acro/issues/96/… – Hanspeter Höschle Jul 24 '17 at 14:26
  • 1
    @clemens : It looks as though the issue is related to the recent l3kernel update, which made \bool_if:n(TF) boolean expression evaluation greedy. I also cannot use acro currently, same error here. Most l3 based pkg need a fix (e. g. media9 fixed yesterday). – AlexG Jul 26 '17 at 10:30
  • Is there a workaround? How can I downgrade? – Jonas Stein Jul 28 '17 at 15:50
3

This issue has been fixed in v2.7c (2017/08/28) which is on its way to CTAN and should be available soon in the major distributions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.