4

I am using shareLaTeX with the XeLaTeX compiler. Still new to the Latex so I cannot resolve the problem...

The only problem is that backref does not work.

\documentclass[10pt,twoside]{mystyle}
\usepackage[utf8]{inputenc}
\usepackage{siunitx}

\usepackage[hidelinks,pagebackref,hyperindex=true]{hyperref}

\usepackage[
backend=bibtex,
style=ieee,
bibencoding=ascii
backref=true
% style=alphabetic
% style=reading
]{biblatex}

\addbibresource{bibliografia.bib}

\begin{document}

Text \cite{alpha}, bla bla bla \cite{bravo}.

\printbibliography[title={Referências Bibliográficas}, notkeyword=carta]

\cleardoublepage
\phantomsection
\addcontentsline{toc}{chapter}{Referências Cartográficas}

\printbibliography[title={Referências Cartográficas}, keyword=carta]

\end{document}

So I get the error:

Package biblatex Error: Imcompatible package 'backref'.

I've tried to use this fix: Formatting back references in bibliography

But for some reason, it does not work for me.

closed as unclear what you're asking by moewe, Stefan Pinnow, CarLaTeX, user36296, Zarko Sep 10 '17 at 14:48

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 5
    Remove option pagebackref and load package hyperref after package biblatex. The document in the question cannot be tested, because of the private class and missing bibliography data. – Heiko Oberdiek Jul 24 '17 at 17:11
  • 1
    @HeikoOberdiek This did in fact resolve the problem with the compatibility issue, however I still do not have back references available in the bibliography. – Focha Jul 25 '17 at 3:04
  • 1
    HeikoOberdiek's suggestions should help. But if your mystyle.cls does weird things and loads other packages that we don't see you might have to do something else. Does mystyle.cls load backref? – moewe Jul 25 '17 at 15:01
  • 1
    Hello @moewe. The suggestion of HeikoOberdiek did work in solving the compatibility issue. But there is no backref working... – Focha Jul 25 '17 at 22:25
  • 1
    Well, the option backref=true turns on the backref, unless something is terribly wrong. Since we can't test your MWE (we don't have your class, .bib files etc.) and you don't show us the output you get, we can only guess. Please give us something more to go on. – moewe Jul 26 '17 at 9:50