I have a lot of trouble getting a working local repository, as well as some standard packages to be found, with MiKTeX 2.9 and TeXstudio 2.12.6. Firstly, I want a local repository on a different drive, E:\Dropbox\MyTeX. I think I have the required TDS structure:

│   ├───bib
│   │   └───misc
│   └───bst
│       └───misc
│   └───rug07
│       └───examples
    │   └───rug07
        │   ├───examples
        │   └───templates

Things I have tried:

  1. Root my Local Directory
  2. Update/Install Packages
  3. Refresh fndb
  4. Update Formats
  5. Reinstalled Miktex without admin privileges.
  6. Repeat

Specifically, there's a .cls file in RThesis and a .sty file in misc that I need. (The files worked blissfully in Overleaf). Any suggestions?

Added Picture 03/08

As you see there is a underline and it states package not found, it compiles fine.

  • 1
    A texmf tree is not a repository so your question is a bit confusing. I never had any problems to store local texmf trees in other drives and to add them to my system. But you should put them in some real folder. It should be E:\mytexmf\tex\latex\.... and not E:\tex\latex. – Ulrike Fischer Jul 27 '17 at 21:14
  • I've changed "E:\Dropbox\MyTeX\tex\latex\" to "E:\Dropbox\MyTeXmf\tex\latex\" and it seems to compile fine now.... kpsewhich returns the repository files locations correctly. But TexStudio claims (not found) for local repository files. Is there an issue with texstudios permissions to find the (new) files and not an issue with Miktex/latex compiling? – DanBernou Jul 28 '17 at 8:07
  • What do you mean by "Texstudio claims"? Can you compile your document on the command line outside texstudio? – Ulrike Fischer Jul 28 '17 at 8:21
  • Both, so now it can find MiKTex (with the local repo) and compile it from within TeXstudio, but the annotation in the TeXstudio IDE says it cannot find those local packages. Is this because the local packages don't have info/reference documents? Something similar happens asweel to newly installed packages (using MPM), latex/MiKTex recognizes them but TeXstudo IDE does not. That is it will still compile regardless but the text editor doesn't recognize them (page is covered in syntax highlighting and underlines). – DanBernou Jul 28 '17 at 8:45
  • I don't use texstudio. Probably there is some way to tell it about new local packages. But as long as miktex can find the packages and compile I wouldn't care too much about if texstudio complains or not ... – Ulrike Fischer Jul 28 '17 at 9:40