0

I have been trying to fix this problem on ubuntu running on virtual box (using texmaker and tex live). I have tried this same code on my windows version of latex (running texmaker and Miktex) and it works. For what ever reason I cannot include an image in my document.

\includegraphics[scale=1]{fig2}

fig2 is in the same folder as the tex document, I have had "fig2.png" included there, and what appears to be every other solution out there to fix the problem including "\graphicspath" etc.

Something that may be notable, when I ran it on my windows computer, I executed through terminal, and Miktex automatically downloaded a package which I believe was for include the image. My thoughts are that I am missing something from the Latex package on ubuntu which is stopping it from finding these files.

When I run the code from above with "fig2", the help function returns "could not find files ending in ..." and lists a bunch of files, none of which are .pdf .png or .jpeg.

Please help!

2
  • 1
    Did you compile with pdflatex and not, say, latex? Can you check if fig2.png is really a .png and not .PNG? Commented Jul 28, 2017 at 15:15
  • 1
    Welcome to TeX.SX!
    – Bobyandbob
    Commented Jul 28, 2017 at 15:18

2 Answers 2

1

So I have found an interesting... thing. In ubuntu, the some of the files in a folder are displayed "name.type" while others are not. Even though my pictures were all png or jpeg when you check them in properties, it wasnt until I downloaded a random cat picture from the internet that the whole file extension was displayed and BAM it worked. SO my solution has been to name the files "name.type" so the whole extension in properties is actually displayed "name.type.type". I thought I had tried this last night but perhaps not this exact thing!

0

You can get this error when compiling with the latex tool instead of pdflatex. Try from a command window (instead of texmaker) running pdflatex . If that works then you need to change the compile method in texmaker to use pdflatex.

1
  • Sadly, returns the same error as before!
    – Matt
    Commented Jul 29, 2017 at 3:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .