0

I have the following article file:

\documentclass[11pt]{article}
\usepackage{cite}

\begin{document}

\title{My Article}
\author{Nobody Jr.}
\date{Today}
\maketitle

Blablabla said Nobody ~\cite{Nobody06}.

\bibliography{mybib}
\bibliographystyle{plain}
\end{document}

In the same folder there is a mybib.bib file that contains the following code:

@misc{Nobody06,
author = "Nobody Jr",
title = "My Article",
year = "2006" }

When I compile using Texmaker, I get the following warning:

Citation 'Nobody06' on page 1 undefined

and a [?] is at the citation place.

I have been compiling the main file with latex, bibtex, latex, latex as suggested in Question mark or bold citation key instead of citation number . And no .bbl file is created.

The .blg file looks like the following:

This is BibTeX, Version 0.99d (TeX Live 2015/Debian)
Capacity: max_strings=35307, hash_size=35307, hash_prime=30011
The top-level auxiliary file: Appendix1.aux
The style file: plain.bst
Database file #1: mybib.bib
You've used 1 entry,
            2118 wiz_defined-function locations,
            508 strings with 4242 characters,
and the built_in function-call counts, 576 in all, are:
= -- 56
> -- 26
< -- 2
+ -- 9
- -- 8
* -- 44
:= -- 90
add.period$ -- 4
call.type$ -- 1
change.case$ -- 6
chr.to.int$ -- 0
cite$ -- 1
duplicate$ -- 24
empty$ -- 44
format.name$ -- 8
if$ -- 127
int.to.chr$ -- 0
int.to.str$ -- 1
missing$ -- 1
newline$ -- 8
num.names$ -- 4
pop$ -- 7
preamble$ -- 1
purify$ -- 5
quote$ -- 0
skip$ -- 20
stack$ -- 0
substring$ -- 37
swap$ -- 13
text.length$ -- 2
text.prefix$ -- 0
top$ -- 0
type$ -- 4
warning$ -- 0
while$ -- 6
width$ -- 2
write$ -- 15

Any idea what I'm missing?

6
  • It works fine for me, i used pdflatex , bibtex, pdflatex, pdflatex.
    – Bobyandbob
    Jul 29 '17 at 8:27
  • Thanks it worked for me using pdflatex. seems to be a Texmaker problem. Jul 29 '17 at 8:33
  • @PeterMølgaardPallesen it should work with latex bibtex latex latex sequence as well and it worked for me only thing the ouput is DVI file instead of pdf. check in texmaker options if you have latex -interaction=nonstopmode %.tex and bibtex %.aux in latex and bibtex locations. one can even automate the compilation using latexmk Jul 29 '17 at 8:39
  • Is the name of your tex-file "Appendix1.tex"? Jul 29 '17 at 8:59
  • 1
    My guess would be (based on the "appendix1.aux" in the blg) that you had set the master file to the wrong file and so texmaker tried to compile something else. Jul 29 '17 at 12:03

Browse other questions tagged or ask your own question.