I am having troubles using the Glossaries Package with some self-built hebrew characters using \libertineGlyph and \makebox. An entry looks like this:

\newglossaryentry{{ע\makebox(-1,8)[r]{\libertineGlyph{uni02DC}}ה}}{name={\RL{{ע\makebox(-1,8)[r]{\libertineGlyph{uni02DC}}ה}},description={‘Peace be with her’ oleho hascholaum}}}




     \usepackage{polyglossia, xunicode}







    \usepackage{multicol,multirow, bigdelim} %%deleted times



    \setmainfont[Ligatures=TeX]{Linux Libertine}
    \newfontfamily\hebrewfont[Script=Hebrew]{Ezra SIL}





    %START GLOSSAR%%%%%%%%%%%%%%%

    %% Glossary Entry
    \newglossaryentry{glosse1}{name={\RL{{ע\makebox(-1,8)[r]{\libertineGlyph{uni02DC}}ה}},description={‘Peace be with her’ oleho hascholaum}}}

    %END GLOSSAR%%%%%%%%%%%%%%





    \newcommand\speaker[1]{\noindent{#1} \einzugjid


    {\textsc{#1}} \einzug




      \pstart     {\RL{\speaker{יוקב.}
       געלטע דאָס גִיט אָבער לאָסטיג
    ?}}  \pend

    \pstart  {\RL{\speaker{בויער.}
      יאָ, דאָס גלעב אייך. הויא פערדיענסט דוא אַהך ניט פֵֿיעל. }}

     \pstart   {\RL{\speaker{יוקב.}
        פֿערדיענט אייכס דאָך אין אַה פֿירטעל יאָהר, וואָהס מייכ‘ס הויא     \edgls{glosse1}  און מאָר קאָסט.
    }} \pend




     \pstart  \speakerd{Person1.} {Gell}, Text…?  \pend

    \pstart   \speakerd{Person 2.} Text…  \pend

    \pstart    \speakerd{Person1.} Text…. \textit{(Seufzt.)} \pend



  • 1
    The first argument of \newglossaryentry must be a label. It can't contain any code in it. The label is used as a reference and is not typeset anywhere. Jul 30 '17 at 10:51
  • This can be – but it also has troubles when I have code inside the specification-part like "name=" or "description=" Is there any idea how I can fix that? Jul 30 '17 at 16:01
  • You need to provide a minimal working example (MWE). Something like \documentclass{article}\usepackage[xindy]{glossaries}\makeglossaries \newglossaryentry{label}{name={\RL{{ע\makebox(-1,8)[r]{\libertineGlyph{uni02DC}}ה}},description={‘Peace be with her’ oleho hascholaum}}}}\begin{document}\gls{label}\printglossaries\end{document} and add the packages that provide \RL and \libertineGlyph. Jul 30 '17 at 16:14
  • Off-topic. Don't load times. It is deprecated anyway and certainly irrelevant here. As @NicolaTalbot said, your label is bad. You need a simple text label here. Note that you aren't making it easy to help because anybody trying to help is going to get errors which are irrelevant. For example, your code requires a glossaries.tex in the directory above the working one, which most people won't have and won't be the same as yours anyhow. Also, if the problem can only be reproduced with that font, we'll need a link. Otherwise, try to use something people are likely to have already.
    – cfr
    Jul 30 '17 at 20:50
  • You need to load polyglossia before setting the languages. Surely you get an error from this? Also hyperref is being loaded too early. Can you not make your example smaller? Do you need the Biblatex and critical edition stuff? (This requests at least one more file only you have and nobody here can access.) I guess you know that geometry is not recommended with KOMA.
    – cfr
    Jul 30 '17 at 20:57

Your code

\newglossaryentry{{ע\makebox(-1,8)[r]{\libertineGlyph{uni02DC}}ה}}{name={\RL{{ע\makebox(-1,8)[r]{\libertineGlyph{uni02DC}}ה}},description={‘Peace be with her’ oleho hascholaum}}}

has a serious problem. The first argument is a label. It's never typeset but is used as a reference (much like \ref and \cite), so there should never be any special characters in the label. With XeLaTeX, it's possible to use extended characters (as long as they're not active). So strip all markup from the first argument:

 description={‘Peace be with her’ oleho hascholaum}}

xindy automatically strips commands and braces, so \makebox(-1,8)[r]{\libertineGlyph{uni02DC}} will end up as (-1,8)[r]uni02DC, which is going to confuse the sorting. It's better to use the sort key to set an appropriate sort value that xindy can understand. For example:

 description={‘Peace be with her’ oleho hascholaum}}

or just

 description={‘Peace be with her’ oleho hascholaum}}

Following on from my answer to your previous question, here's a MWE:



\setmainfont[Ligatures=TeX]{Linux Libertine O}

\newfontfamily\hebrewfont[Script=Hebrew]{Keter YG}



{% base it on the tree style:
  % switch to german
     \setlength{\parskip}{0pt plus 0.3pt}%

 description={‘Peace be with her’ oleho hascholaum}}






image of document

  • thank you so much for your work! It would be nice if this would work, but unfortunately it doesn't. Your minimal example as well as when I put it into my document; see: overleaf.com/10443287pndzdjcfndjy (wich editor do you use? With TexShop (latest updates) this doesn't work :( ) Jul 31 '17 at 16:41
  • @לאהפּאַסטעך That link isn't my minimal example. What happened when you tried to compile my example (without adding extra code to it)? In what way didn't it work? Any error messages? (I just use vim and run xelatex and makeglossaries from the terminal.) Have you tried building up my example from the start like I did? At what point did it stop working? Jul 31 '17 at 17:02
  • with TexShop it doesn't give an error-message with your code above; but it also doesn't print a glossarie. But I get this Package glossaries Warning: No language module detected for 'hebrew'. (glossaries) Language modules need to be installed separately. (glossaries) Please check on CTAN for a bundle called (glossaries) 'glossaries-hebrew' or similar. With overleaf I get errors (overleaf.com/10443287pndzdjcfndjy) – but that is an overleaf problem I think Jul 31 '17 at 17:38
  • 1
    @לאהפּאַסטעך No, it's not an error. It's a warning. You can ignore it and provide your own translation through the title option (as I did in one of my examples). If you still can't get the glossary to appear, try What can interfere with glossaries to prevent printing? Aug 1 '17 at 12:32
  • 1
    @לאהפּאַסטעך Using a terminal on Linux (should be much the same as on a Mac) and assuming the file is called test.tex: xelatex test; makeglossaries test; xelatex test. Principle dependencies: glossaries v4.30 2017-06-11, makeglossaries v2.21, glossaries-german.ldf v1.0, tracklang v1.3.4 2017/03/25, polyglossia v1.42.4 2015/03/25, Perl v5.18.4 (add \listfiles to the document to get a summary at the end of the transcript) Aug 4 '17 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.