2

I'm new to LaTex. I'm using TexMaker and Tex Live 2017, with BibTex 0.99d. Sadly i run this on Windows 10. So the Problem is, i use the output file "build" for a better overview on the data-files.enter image description hereBut when i compile with those fast compiling settings settings, i get only question marks in brackets [?] as citation and this massage:

`Process started

This is BibTeX, Version 0.99d (TeX Live 2017/W32TeX) The top-level auxiliary file: build/main.aux I couldn't open auxiliary file titel.aux ---line 23 of file build/main.aux : \@input{titel.aux : } I'm skipping whatever remains of this command The style file: abbrv.bst Database file #1: masterbib.bib Warning--there's a number but no volume in "literature9999" (There was 1 error message)

Process exited with error(s)`

When i do not use the "build" output file everything works fine. As you can see i already modified the "Bib(la)tex" command to "bibtex build/%". I found this in BibTeX error in TexMaker {I couldn't open file name `test_bb.aux'}. But it does not work for me.

Glad for every help.

Greetings Vince

  • 2
    I'm not new to latex and I never use such build folders. Why fight with unusual file locations? – Ulrike Fischer Jul 31 '17 at 10:52
  • 1
    using a separate folder for the axillary files will just make your life way more complicate. In case you use the build option to keep your directory "clean", have a look at tools like github.com/akerbos/ltx2any instead. – user36296 Jul 31 '17 at 11:06
  • see tex.stackexchange.com/a/313228/36296 – user36296 Jul 31 '17 at 11:51
  • In contrast, many of us do find it convenient to have a separate build directory to avoid polluting the source directory. Latex, pdflatex, etc have an -output-directory option to support this. The primary problem is that bibtex alone doesn't. – John Collins Jul 31 '17 at 15:20
  • 1
    In the original post, the commands configured in TeXMaker appear wrong: 1. pdflatex and lualatex would normally have an -output-directory to use a build directory. 2. The normal bibtex command does not work properly with a build directory. I suggest an easy solution might be to use latexmk, which is already programmed to take care of properly using a build directory; then also you don't have to worry about the separate commands. (But you'd have to work out if there any complications in using TeXMaker with latexmk configured to use a build directory.) – John Collins Jul 31 '17 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.