7

Does the newest fnpct package have a bug in it? The following works with (the frozen version of) TeX Live 2016 but not with TeX Live 2017

\documentclass{article}

\usepackage{fnpct}

\begin{document}
The cow jumped\footnote{over the moon}.
\end{document}

After loading texmf-dist/tex/latex/translations/translations-basic-dictionary-english.trsl, it complains

! Undefined control sequence.
\@trnslt@ifstrequal #1#2->\ifnum \pdf@strcmp 
                                             {\unexpanded {#1}}{\unexpanded ...
                                         {\unexpanded {#1}}{\unexpanded ..."

1 Answer 1

8

There is a bug not in fnpct but in translations, which it loads. The latter uses \pdf@strcmp from pdftexcmds but does not explicitly load it. You can therefore fix with

\documentclass{article}
\usepackage{pdftexcmds}
\usepackage{fnpct}

\begin{document}
The cow jumped\footnote{over the moon}.
\end{document}

(Likely this happens as in the past pdftexcmds was loaded by a number of packages, including expl3 and the pdfTeX graphics driver. That code has been cleaned up, which exposes any implicit dependencies.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .