1

Today, I tried to install the latest version of TexLive (see https://www.tug.org/texlive/) on Windows 10. However, the installation always fails. I tried twice so far and the customization means mostly, that I disable all kinds of languages which I do not need (besides English) and the text editor.

Here is the error log. The error seems always to be connected to TLUtils and TLPDB. I found that several other users had the same problem, but there does not seem to be a real solution. Some post that it worked after several attempts, others post that it only works with an ISO image of Tex Live, etc.

Loading http://vesta.informatik.rwth-aachen.de/ftp/pub/mirror/ctan/systems/texlive/tlnet/tlpkg/texlive.tlpdb
  Installing TeX Live 2017 from: http://vesta.informatik.rwth-aachen.de/ftp/pub/mirror/ctan/systems/texlive/tlnet (not verified)
  Platform: win32 => 'Windows'
  Distribution: net  (downloading)
  Using URL: http://vesta.informatik.rwth-aachen.de/ftp/pub/mirror/ctan/systems/texlive/tlnet
  Directory for temporary files: C:\Users\XYZ\AppData\Local\Temp\0Dj9402Jdj
  Installer revision: 44918
  Database revision: 44936
  Settings:
    [...]
  total_size: "3819"
  Installing to: C:/texlive/2017
  Not an admin install; not making read-only
  Not an admin install; not making read-only
  Not an admin install; not making read-only
  Not an admin install; not making read-only
  Installing [0001/2913, time/total: ??:??/??:??]: 12many [376k]
  Installing [0002/2913, time/total: 00:04/05:53:16]: 2up [66k]
  Installing [0003/2913, time/total: 00:05/06:16:03]: Asana-Math [482k]
  Installing [0004/2913, time/total: 00:06/03:35:31]: ESIEEcv [137k]
  Installing [0005/2913, time/total: 00:07/03:39:03]: FAQ-en [4971k]

  [...]

  Installing [0896/2913, time/total: 23:43/01:20:15]: epspdfconversion [412k]
  Installing [0897/2913, time/total: 23:53/01:20:46]: epstopdf [23k]
  Installing [0898/2913, time/total: 23:54/01:20:49]: epstopdf.win32 [1k]
  Installing [0899/2913, time/total: 23:54/01:20:49]: eqell [180k]
  TLUtils::check_file: removing C:\Users\XYZ\AppData\Local\Temp\0Dj9402Jdj\N3oJ6a9ziv\eqell.doc.tar.xz, sizes differ:
    TLUtils::check_file:   TL=127020, arg=183208
  TLPDB::_install_package: downloading did not succeed
  Installation failed.
  Rerunning the installer will try to restart the installation.
  Or you can restart by running the installer with:
    install-tl-windows.bat --profile installation.profile [EXTRA-ARGS]
  or
  install-tl-advanced.bat --profile installation.profile [EXTRA-ARGS]

Any one knows what the issue could be? Thanks for any hints.

  • 1
    This appears to be related to a similar problem sometimes seen with MiKTeX: There is a failure when trying to access a file written somewhere in a Local/Temp directory. Possibly related to permissions, but it's hard to assign permission to a file that does not yet exist. Just recently, I installed a custom selection of TeXLive 2017 on Windows 10 to a subdirectory of my home directory (not to C:\texlive) and there were no problems at all. – user139954 Aug 2 '17 at 18:41

Browse other questions tagged or ask your own question.