0

I have a main.aux file in the folder /248239j/Latex/main.aux.

In the preferences within Configure Texmaker I have the Bib(la)tex set to: %.aux

I am receiving the error: could not start the command: "main".aux

  • Welcome to TeX.sx! The signature in the text question is not needed in this site as your username is showed at the bottom. Avoid also thanks and asking help , since this is already assumed and we try to maintain concise questions. Your thanks will we showed when you accept/upvote the questions. – Fran Aug 3 '17 at 7:10
  • I guess that the main.aux file is not in the same directory that main.tex and that /248239j/Latex/ is not searchable (is not into the path) or maybe the latex file is not named main.tex, but with this information it is not clear what you are trying to do. – Fran Aug 3 '17 at 7:21
  • "main.aux" isn't a command, it should be something like biber % in the configuration, if you want to use biber and bibtex % if you want to use bibtex. In both cases don't add the extension, it is not needed and for biber .aux is wrong anyway. – Ulrike Fischer Aug 3 '17 at 7:53
  • thanks, Yes changing the configuration file fixed this. How do I mark this as answered. – Melanie Ann Tarr Aug 26 '17 at 4:01
  • @Ulrike Do you want to add an answer or do we have a duplicate around? – Johannes_B Nov 9 '17 at 7:01
1

Only using %.aux in the configuration is wrong, this expands only to a file name. There must be some application before. With your setting texmaker is trying to call the command main.aux and this naturally fails.

Correct would be in the configuration something like biber %, if you want to use biber and bibtex % if you want to use bibtex. In both cases don't add the extension, it is not needed and for biber .aux is wrong anyway.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.