2

I am working on my thesis at the moment and I have the following problem:

I want to customize the bibliography so that the surname is shown first (and the first name is shortened), ISBN and DOI should be left out.

I read the following article: Biblatex: Get rid of ISSN, URLs and DOIs in references. So according to this I applied the suggested customizations, but it seems that none of them work for my document.

Here is my code:

\documentclass[a4paper,                         
               12pt,                            
               oneside,                         
               toc=listof,                     
               listof=entryprefix,              
               headings=normal                  
               ]{scrreprt}                 

  \usepackage[ngerman]{babel}                   
  \usepackage{blindtext}

 \usepackage[backend=biber,                      
             bibencoding=utf8,                      
             style=alphabetic,                  
             doi=false,                         
             isbn=false,
             dashed=false,                          
             uniquename=false,                  
             ]{biblatex}                            
 \addbibresource{bib/literatur.bib}     

 \begin{document}

 \blindtext \cite{Black.1973}

 \printbibliography

 \end{document}       

And here is my bib-file:

% This file was created with Citavi 5.5.0.1

@article{Black.1973,
 author = {Black, Fischer and Scholes, Myron},
 year = {1973},
 title = {The Pricing of Options and Corporate Liabilities},
 pages = {637--654},
 pagination = {page},
 volume = {81},
 number = {3},
 issn = {0022-3808},
 journal = {Journal of Political Economy},
 doi = {10.1086/260062}
}

And here are screenshots of the result I'm getting:

Text bibliography

Here is the code from my .blg file:

[0] Config.pm:354> INFO - This is Biber 2.7
[0] Config.pm:357> INFO - Logfile is 'test.blg'
[43] biber-MSWIN32:303> INFO - === 
[79] Biber.pm:359> INFO - Reading 'test.bcf'
[184] Biber.pm:835> INFO - Found 1 citekeys in bib section 0
[200] Biber.pm:3670> INFO - Processing section 0
[222] Biber.pm:3840> INFO - Looking for bibtex format file 'bib/literatur.bib' for section 0
[230] bibtex.pm:1435> INFO - Decoding LaTeX character macros into UTF-8
[239] bibtex.pm:1292> INFO - Found BibTeX data source 'bib/literatur.bib'
[247] Utils.pm:164> WARN - BibTeX subsystem: C:\Users\FSCHAR~1\AppData\Local\Temp\tksrf7X3UK\literatur.bib_10088.utf8, line 3, warning: 45 characters of junk seen at toplevel
[258] UCollate.pm:68> INFO - Overriding locale 'de-DE' defaults 'normalization = NFD' with 'normalization = prenormalized'
[258] UCollate.pm:68> INFO - Overriding locale 'de-DE' defaults 'variable = shifted' with 'variable = non-ignorable'
[258] Biber.pm:3499> INFO - Sorting list 'anyt/global/' of type 'entry' with scheme 'anyt' and locale 'de-DE'
[259] Biber.pm:3505> INFO - No sort tailoring available for locale 'de-DE'
[261] bbl.pm:608> INFO - Writing 'test.bbl' with encoding 'ascii'
[261] bbl.pm:712> INFO - Output to test.bbl
[262] Biber.pm:109> INFO - WARNINGS: 1
4

The alphabetic style does not know the option dashed, so calling that option will cause an error. So we will have to drop that option.

uniquename=false, does not make sense with the style you use here.

With giveninits=true you can get initials of first names.

So you will want to use biblatex with

\usepackage[backend=biber, style=alphabetic, doi=false, isbn=false, giveninits=true]{biblatex}    

Finally you want

\DeclareNameAlias{author}{family-given}
\DeclareNameAlias{edi‌​tor}{family-given}
\D‌​eclareNameAlias{tran‌​slator}{family-given‌​}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.