4

Recently, MikTeX released a version for ubuntu-like systems, so I thought to give a try. I followed the official instructions and everything worked perfect.

However, when I tried to compile my document with LuaLaTeX engine I got the following error:

This is LuaTeX, Version 1.0.4 (MiKTeX 2.9.6400) restricted system commands enabled. I can't find the format file `lualatex.fmt'!

My question is whether this is a miktex problem or if I have to further setup my system

4
  • Maybe you have to install some extra from MikTeX.
    – Sigur
    Commented Aug 4, 2017 at 15:58
  • Maybe you can, as under Windows, create/update the format using something like mo_admin (for Windows, this is a graphic interface to refresh the FNDB, declare new TeX roots or update the formats.
    – Bernard
    Commented Aug 4, 2017 at 15:59
  • @Sigur miktex does not mention that extra fonts installation is necessary
    – Yorgos
    Commented Aug 4, 2017 at 16:06
  • @Bernard unfortunately, i don't know how to do it in ubuntu, since i cannot find a tutorial/guideline at the official site
    – Yorgos
    Commented Aug 4, 2017 at 16:08

2 Answers 2

1

For anyone who wants to give a try to MikTeX

Following Bernard's recommendation I managed to overcome compiling problems by updating FNDB. In order to do so, I used the following command:

sudo initexmf --admin --update-fndb

(you can skip sudo, if you remove the admin option). Alternative, I believe that the command sudo mpm --admin --update-db may also work (unfortunately, `MikTeX Package Manager (mpm) does now work for me).

You can find more details at MikTeX's page on Git Hub.

5
  • I hope it asks for authentication since this is installing under /usr/local.
    – cfr
    Commented Aug 4, 2017 at 22:22
  • 1
    since you add --admin option, your system mentions that you need to execute the command as a superuser (i.e sudo).
    – Yorgos
    Commented Aug 5, 2017 at 8:29
  • How does the on-the-fly installation work, then? It asks for authentication before proceeding?
    – cfr
    Commented Aug 5, 2017 at 12:00
  • when you install miktex you automatically accept on-the-fly option. so, you do not need to enable it manually. however, you can do it with the following command sudo initexmf --admin --set-config-value [MPM]AutoInstall=1. please have a look at the link on my answer for further details
    – Yorgos
    Commented Aug 6, 2017 at 8:39
  • That strikes me as quite dodgy. I'm not sure anything should be able to modify system software in that way without getting explicit permission. It means something is getting run with privileges somehow ....
    – cfr
    Commented Aug 6, 2017 at 13:00
0

All the propositions read here failed.
I then just uninstalled completely MikTex with Synaptic and the error disappeared. I must say I had texLive installed and it took the relay as stated by

This is LuaTeX, Version beta-0.80.0 (TeX Live 2015/Debian) (rev 5238).

instead of the MikTex 1.0.4 version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .