1

I get an error message on 64-bit MikTex for the following minimal example:

\documentclass{article}
\usepackage{physics}
\begin{document}
Hello world
\end{document}

What can be possibly going wrong? I tried everything I know.

3
  • @TorbjørnT.Package: physics (./xparse.sty (./expl3.sty (c:/texlive/2017/texmf-dist/tex/latex/l3kernel/l3names.sty Package: l3names 2017/03/18 Obsolete L3 package
    – Avi
    Aug 6, 2017 at 0:34
  • Right, so it seems that both xparse.sty and expl3.sty is found in the same folder as your .tex file. Which is wrong, those should also be in c:/texlive/.... The first place LaTeX looks for files is, I think, the current folder. So presumably, if you delete those local copies of xparse and expl3 (or even have the .tex file in a different folder), it would work. Aug 6, 2017 at 7:53
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Joseph Wright
    Aug 11, 2017 at 5:04

1 Answer 1

2

Your .log file seems to show that both xparse.sty and expl3.sty are located in the same folder as your .tex file, while they should have been in c:/texlive/2017/..., as is the case with l3names.sty. The first place LaTeX looks for files is, I think, the current folder. So presumably, if you delete those local copies of xparse and expl3 (or even have the .tex file in a different folder), it would work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.