0

I don't even know where to start. My document was running fine until I added a citation to my bibtex file that crashed the bibliography. This has happened before, and I've been able to copy the contents of the latex file to a new .tex file, and create a new .bib file by copying over the citations that worked.

But this time when I copy over the .tex file it still crashes (without the bad reference). I've deleted all of the original copies of EVERYTHING, reinstalled mikTex and TexStudio. Emptied the recycle bin. The only thing I kept were the figures I needed, and I copied over the latex content to a brand new file (same with bibliography). I've also tried creating a document with only on reference and a .bib file with just that reference. That doesn't run either. I don't know what part of my code to give because it's a fairly large document....

Any help will be so so so appreciated.

EDIT: I apologize for the lack of code. I was kind of overwhelmed. I'm not sure why, but what worked for me was deleting, then re-typing all of the \cite{authoryear} commands within the document. This was after I had copied over the document contents to a new file, and also created a new .bib with the references that worked. I have no idea why this was successful. Any input?

  • 3
    Welcome to the tex stack community. We don't do black magic in here to figure out the actual cause of your problem. Please provide us with the actual code or at least provide us with a minimal working example that actually generates the error. Otherwise, you're risking your post to be closed or put on hold. – CroCo Aug 6 '17 at 4:26
  • 1
    Welcome, does a simple helli world example run? If not, why? Errors? Did you remove the aux files? – Johannes_B Aug 6 '17 at 4:38
  • 1
    If you don't know what a MWE is, see here: minimal working example with bibliography (MWEB). – CarLaTeX Aug 6 '17 at 5:13
  • 2
    You wrote, "I've also tried creating a document with only on[e] reference and a .bib file with just that reference. That doesn't run either." Well, if your document compiles correctly without that particular \cite instruction, then that instruction must be the main problem, right? Please post a minimal LaTeX file with just the \cite directive in question, along with a minimal bib file that contains just the bibliographic entry you're trying to cite. The objective, for now, is to come up with a reproducible error. – Mico Aug 6 '17 at 6:06
  • Probably Just a Glitch in The Matrix. – Johannes_B Aug 7 '17 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.