I am typesetting a book with verses in three languages. The verses are typeset to appear in three columns using Reledpar. I also need three different indexes of these verses in the three languages, so I am using imakeidx to generate these.

However, TOC is not getting generated for my book. After many trials, I found that the problem is with Reledpar. If I remove this package, both TOC and imakeidx work perfectly. As soon as I introduce Reledpar, this is the error I get

No file testing_multiple_index.toc. ! No room for a new \write. \e@ch@ck ...message {No room for a new \string #4} \fi \fi l.24 ^^I\tableofcontents ?

Here is a MWE

\documentclass[12 pt, twoside]{extbook} %extarticle provides additional font-sizes

%for index
\makeindex[name=eng,title=Alphabetical Index of Verses]
\makeindex[name=dev,title=Index of verses]

%parallel typesetting
\setgoalfraction{0.8} % for reledpar error in finishing pages




\chapter {Chapter 1}

\section {Section A}

    This is a test line. \index[eng]{a verse}
    This is a test line. 
    This is a test line. \index[dev]{sanskrit verse}
    This is a test line. 
    This is a test line. 

\section {Section B}
    This is a test line. \index[eng]{another verse}
    This is a test line. 
    This is a test line. 
    This is a test line. \index[dev]{sanskrit verse 2}
    This is a test line. 



  • 2
    Can you try adding \usepackage{morewrites} and see if it works for your main doc? (It works for the minimal example in the question.) There is more discussion of a probably similar "No room for a new \write" problem at this question and this question. – ShreevatsaR Aug 7 '17 at 19:15

As explained by ShreevatsaR you can use morewrites package.

But before doing that:

  1. As explained in reledmac handbook, you must respect this order
    1. Load imakeidx
    2. Load reledmac
    3. Declare your index.

The order is very important.

Last but not least: if you don't use the endnotes / eledsection tools of reledmac, use noeledsec and noend optiions when loading eledmac. You will get better results, and you should solve your No room for a new \write and consequently solve your bug without morewritespackage. You could also use one of the "performance option" described in § 4.2 of reledmac handbook.

Ps : there is a § "No room for a new"… in reledmac handbook

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.