0

I'm running texlive 2016 from the official repo on fedora 26, and using texstudio as a composer.

I get the following error while trying to compile

warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/bin:/usr/bin/share/texlive/texmf-local/web2c:/usr/bin/share/texlive/texmf-dist/web2c:/usr/bin/share/texlive/texmf/web2c:/usr/bin/texmf-local/web2c:/usr/bin/texmf-dist/web2c:/usr/bin/texmf/web2c:/usr:/usr/share/texlive/texmf-local/web2c:/usr/share/texlive/texmf-dist/web2c:/usr/share/texlive/texmf/web2c:/usr/texmf-local/web2c:/usr/texmf-dist/web2c:/usr/texmf/web2c:/usr/share/texmf-local/web2c:/usr/share/texlive:/usr/share/texlive/share/texlive/texmf-local/web2c:/usr/share/texlive/share/texlive/texmf-dist/web2c:/usr/share/texlive/share/texlive/texmf/web2c:/usr/share/texlive/texmf-local/web2c:/usr/share/texlive/texmf-dist/web2c:/usr/share/texlive/texmf/web2c. kpathsea: Running mktexfmt latex.fmt mktexfmt: No such file or directory

Obviously I tried with different text, even the simplest "hello world" gives error. before installing texlive 2016 I used the tar.gz provided on the official site. I was getting the same error, so I asked a friend who uses texlive and texstudio on fedora, he said that the insallation from the repo was fine for him, so I decided to unistall texlive 2017 by following this "guide" and changing paths to the right ones.

After cleaning up I installed texlive 2016 from the repo, but the error persists. I'm starting to think that the previous installation messed up something even if a tried cleaning up everything.

can anybody help me?

  • Welcome to TeX.X! The problem should be independent from Texstudio. So I've removed the tag. I do not have fedora, so I don't know where texmf.cnf should be there. But can you search for the file? There may be more than one, e.g., at /etc/* or somewhere below /usr/share. – Schweinebacke Aug 8 '17 at 8:59
  • This might help. – luchonacho Aug 8 '17 at 9:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.