1

I'm writting my thesis and I would like to customize my bibliography in order to respond to the french style. In my pdf I have "title" and I don't want them. I see I could use plain-fr on these website: http://www.cuk.ch/articles/4014 This is my code:

\documentclass[french]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[a4paper]{geometry}
\usepackage{graphicx}
\usepackage{natbib}
\usepackage{csquotes}
\usepackage[defernumbers=true,backend=bibtex,bibstyle=authoryear,citestyle=authoryear,firstinits=false,maxcitenames=1,maxbibnames=10]{biblatex}
\renewbibmacro{in:}{}
\DefineBibliographyExtras{french}{\restorecommand\mkbibnamefamily}
\usepackage{babel}
\bibliographystyle{plain-fr}

\renewcommand{\baselinestretch}{1.5}

\bibliography{bibliobon}

    \begin{document}

    example \cite{author}
    \printbibliography
    \end{document}

When I try to compile I got this error: Package biblatex Error: '\bibliographystyle' invalid. \bibliographystyle{plain-fr}

How can I use this style? Thanks a lot for your answers.

  • plain-fr is not a biblatex style. You'll have either to complie the bibliography with plain-fr+bibtex (and delete all commands in relation with biblatex) or use biblatex and customise the authoryear style to obtain exactly what you want. B.t.w. the syntax \bibliography{bibliobon} is not for biblatex: you should use \addbibresource{bibliobon.bib} (with the extension) ,and remove \bibliographystyle, which is for bibtexwithout biblatex. – Bernard Aug 8 '17 at 21:57
  • @Bernard Hello, Thanks a lot for your quick answer but I don't understand. Because I have backend=bibtex in my preamble. Where I have to put the bibtex? If I put it instead of biblatex I have this error: File `bibtex.sty' not found. ^^M. How to use plain-fr without the bibliographystyle? Thanks for your answer. – DBarbara Aug 9 '17 at 19:37
  • Plain corresponds to the numeric style of biblatex, and it's the default. babel-french will take care of most features – if not all – of plain-fr. You also have to load csquotes with options autostyle, so that it takes babel into account and french=guillemets for the rules of the Imprimerie Nationale. – Bernard Aug 9 '17 at 20:06
  • Oh! b.t.w., natbib and biblatex will conflict. Also, unless you have a serious reason, you should usebiber as a backend if you want to take advantage of all the possibilities of biblatex/biber (amongst these, biber understands utf8). – Bernard Aug 9 '17 at 20:10
  • @Bernard Hello, Thanks again for your answer. Your solution compile with in the premable:\usepackage[french]{babel} and \usepackage[autostyle]{csquotes} but I still have the guillemets. Did you know a another thing I can change? Thanks for your help. (Sorry ctr+k doesn't work in my comment) – DBarbara Aug 11 '17 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.