1

Update: I'm part of the way to a solution. This works:

\setmainfont{EBGaramond}[
  UprightFont = /Users/moacir/Library/Fonts/EBGaramond ,
  % Pick a system font that is also .otf:
  BoldFont = /System/Library/Fonts/SFNSDisplayCondensed-Thin ,
  Extension = .otf
]

So not using the Path option in fontspec is one way around this.

But if I remove the Extension, like this:

\setmainfont{EBGaramond}[
  UprightFont = /Users/moacir/Library/Fonts/EBGaramond.otf ,
  BoldFont = /System/Library/Fonts/SFNSDisplayCondensed-Thin.otf
]

This happens:

/usr/local/texlive/2017/texmf-dist/web2c/mktexnam: Could not map source abbreviation E for EBGaramond.

In other words, it can't find EBGaramond unless Extension is defined. But if I define it, then I can't use Helvetica Bold. It's not an .otf, but rather it's hiding inside /System/Library/Fonts/Helvetica.dfont.

Finally, if I change out EB Garamond for Humboldt Fraktur (/Users/moacir/Library/Fonts/HumboldtFraktur-Regular.ttf), I get a similar looking error, meaning EB Garamond is not responsible:

/usr/local/texlive/2017/texmf-dist/web2c/mktexnam: Could not map source abbreviation H for HumboldtFraktur-Regular

Because EB Garamond doesn't have a bold associated with it, the rare times I need a bold face, I use Helvetica Bold, instead. I used to do this:

\setmainfont[BoldFont={Helvetica Bold}]{EB Garamond}

This works great as long as the computer can find EB Garamond. When it can't, which seems to be increasingly often, then I'm out of luck. But if I try:

\setmainfont{EBGaramond}[
  Path = /Users/moacir/Library/Fonts/,
  BoldFont = {Helvetica Bold} ,
  Extension = .otf
  ]

it looks for Helvetica inside the path I have defined:

kpathsea:make_tex: Invalid fontname `[/Users/moacir/Library/Fonts/Helvetica Bold.otf]/OT', contains '['

That's not where it is; it's a system-loaded font. How can I tell it to find Helvetica?

  • 3
    Why don't you use Garamondx or the recent CormorantGaramond for your bold font? – Bernard Aug 9 '17 at 20:17
  • 1
    Mixing it with a bold is really an abuse of EB Garamond and should be reported to the International Society for the Protection of Font Faces. However, since the ISPFF does not yet exist, one of the options @Bernard suggests would surely be preferable. Why are you using EB Garamond in your personal set of fonts? Does FontBook not know about those installed as part of TeX Live? By the way, do you have the same problem with LuaTeX or is this XeTeX specific? – cfr Aug 9 '17 at 23:05
  • My question isn't EB Garamond specific. What if I wanted to use a locally installed font, Foo, as the main font and a system font, Bar, for the BoldFont? Is that possible, is what my question is asking. – Moacir Aug 11 '17 at 6:00
  • @cfr I appreciate the aesthetic concern--the main reason I use "bold" is that section, etc, headings are put in bold, and I prefer those to be in a sans-serif font. As far as I can tell, Font Book does not see any TeX fonts (a search in the app for "computer modern" comes up blank). As for EB Garamond, I like it, and I don't see why any of the problems I have been having with it and fontspec are specific to the font, because I can recreate the exact error using other fonts. The problem is how fontspec sees user-installed fonts, imo. – Moacir Aug 11 '17 at 6:38
  • Somewhat kludgy, but presumably workable: Create a symbolic link from the actual Helvetica Bold font file into the directory /Users/moacir/Library/Fonts/ (or wherever the main font is located). – Mico Aug 11 '17 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.