0

I was trying to compile a TeX file for the very first time. In turns out, fonts I use are not included in the vanilla copy of MikTeX 2.9, and trying to compile my TeX file redirected to install the package for it on the fly. It turned out my disk was full, so the installation failed. Now, it just sees that that package failed to install, and does not try to install it again.

I tried re-copying all the files from a vanilla copy of MikTex 2.9, but that did not make the install-packages-on-the-fly come back. How can I make the MikTeX try to install this package again?

I am running this in Windows.

  • Have you tried to uninstall this package using the MikTeX package manager (or install it from there)? – epR8GaYuh Aug 12 '17 at 15:37
  • Problem is, I don't remember what package it was. Will the package manager tell me which packages failed to install? – Alex Aug 12 '17 at 15:39
  • Which fonts do you want to use? – Bernard Aug 12 '17 at 15:42
  • 1
    It is trying to make bitmap fonts, instead of using the type 1 fonts. This means it doesn't find the latter. Try running from the command line -updmap --verbose (the switch is to see what happens), and recompile. – Bernard Aug 12 '17 at 16:10
  • 1
    Oh! In practice, it's very simple: when a font is installed and you see a message mentionin makepk at compiation, it means it's not mentioned and the type 1 font databases, and you have to run updmap to do it. – Bernard Aug 12 '17 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.