0

I'm trying to find the minimum required texlive installation for Ubuntu 16.04 (https://packages.ubuntu.com/de/xenial/tex/texlive) in order to compile a document with LuaLaTeX. Unfortunately, with texlive and texlive-latex-recommended I receive this error:

! LaTeX Error: File `ucharcat.sty' not found.

How can I figure out which installation would be suitable and contain the required .sty files?

  • 1
  • 1
    In particular apt-cache search ucharcat returns texlive-luatex for me. – gusbrs Aug 12 '17 at 21:22
  • With a minimal installation, errors like that will keep popping up. Instead of looking up the meta package, installing that, going on, looking up the next missing package, installing that .... i would just download vanilla TeX Live from TUG. I installed it last week on Ubuntu, it took almost two hours, but i have all i need. – Johannes_B Aug 13 '17 at 5:13
  • Thank you, @gusbrs and @Johannes_B. apt-cache was very helpful to find the most commonly needed packages. This way, I could create a Docker image that is 2GB large compared to the 3GB of the -full installation. Well... Better than nothing :-) – user3105453 Aug 13 '17 at 11:14

Browse other questions tagged or ask your own question.