1

I would like to cite a paper by Bibtex. The bib entry is

@Article(Zolandek2007,
title = {The {PF030405a} {‘‘Krzeszowice’’} fireball},
author = {P. {\.{Z}}o{\l}\c{a}dek and A. Olech and M. Wi\'{s}niewski and M. Kwinta},
journal = {Earth, Moon, and Planets},
year = {2007},
volume = {100},
number = {3--4},
pages = {215--224},
file =        f
)

Bibtex omits the dot between \ and {Z}, so the entry in bbl file looks like this:

\bibitem[{\.{Z}o{\l}\c{a}dek et~al(2007)\.{Z}o{\l}\c{a}dek, Olech,
  Wi\'{s}niewski, and Kwinta}]{Zolandek2007}
\{Z}o{\l}\c{a}dek P, Olech A, Wi\'{s}niewski M, Kwinta M (2007) The {PF030405a}
  {‘‘Krzeszowice’’} fireball. Earth, Moon, and Planets 100(3--4):215--224

LaTeX then announces error Extra }. If I finish translation in spite of it, the result

{Zołądek P, Olech A, Wiśniewski M, Kwinta M (2007) The PF030405a Krzes- zowice fireball. Earth, Moon, and Planets 100(3–4):215–224

begins with a wrong brace, the dot above Z is missing and also quotation marks around word Krzeszowice are missing. Does anybody have any advice, how to cite papers with so complicated names?


I have read the answers to the question "How to write “ä” and other umlauts and accented letters in bibliography?" I have tried all the characters proposed there:

{\"a}{\^e}{\`i}{\.I}{\o}{\'u}{\aa}{\c c}{\u g}{\l}{\~n}{\H o}{\v r}{\ss}.

Everything works except {\.I}. After Bibtex, the dot is off and LaTeX does not know the order \I.

I use these documentclass and packages:

\documentclass[smallextended]{svjour3}
\usepackage{graphicx}
\usepackage{amsmath}
\usepackage{multirow}
\usepackage{natbib}
\usepackage{color}
\usepackage{tikz}
\usetikzlibrary{shapes.geometric, arrows, calc}

The natbib package could theoretically influence it, but it works by the same way both with and without natbib.

  • 2
    Welcome to TeX.SX! Please make your code compilable (if possible), or at least complete it with \documentclass{...}, the required \usepackage's, \begin{document}, and \end{document}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem. – Stefan Pinnow Aug 16 '17 at 13:26
  • You must input the surname as {\.Z}o{\l}{\c a}dek, or, better still, as {\.Z}o{\l}{\k a}dek -- you want an "ogonek", not a "cedilla", under "a", right? If you want to typeset the ogonek accent, be sure to load the fontenc package with the option T1. – Mico Aug 16 '17 at 13:35
  • 2
    To typeset the double quotation marks around Krzeszowice, be sure not to use ‘‘ and ’’ (aka "smart" quotes) unless you use either XeLaTeX or LuaLaTeX; even then, you will probably also have to load the fontspec package and use a suitable font. Just use double-backquotes and double-apostophes, as is uniformly recommended in just about every introduction to TeX and LaTeX. – Mico Aug 16 '17 at 13:40
  • 1
  • 2
    I get the dot over I with \.I; a Polish author named Żołądek should be input as {\.Z}o{\l}{\k{a}}dek with the correct ogonek. You need \usepackage[T1]{fontenc}; the quotes can be input as and (not ‘‘ and ’’), but for those you need \usepackage[utf8]{inputenc} (if your document is UTF-8). – egreg Aug 16 '17 at 16:22
0

I had the same problem with the the bibtex style jss.bst which has a function (remove.dots) that removes dots in the input. Since the dot was removed the other suggested solution in the comments to the original post did not work, but I found another solution which is to encode the backslash and the dot using ASCII hexadecimal codes using TeX's ^^ substitution mechanism. The backslash is ^^5c and the dot is ^^2e, so your bibtex entry would look like this:

@Article(Zolandek2007,
title = {The {PF030405a} {``Krzeszowice''} fireball},
author = {P. {^^5c^^2eZ}o{\l}\c{a}dek and A. Olech and M. Wi\'{s}niewski and M. Kwinta},
journal = {Earth, Moon, and Planets},
year = {2007},
volume = {100},
number = {3--4},
pages = {215--224},
file =        f
)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.