3

When I run the code

\documentclass{article}
\begin{document}
Hello world!
\end{document}  

with the iso version of Tex live 2017 using xelatex, my running gets about a 10 seconds pause with this warning on command line:

This is XeTeX, Version 3.14159265-2.6-0.99998 (TeX Live 2017/W32TeX) (preloaded format=xelatex)
 restricted \write18 enabled.
entering extended mode
(./test.tex
LaTeX2e <2017-04-15>
Babel <3.10> and hyphenation patterns for 84 language(s) loaded.
(c:/texlive/2017/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(c:/texlive/2017/texmf-dist/tex/latex/base/size10.clo

and then automatically continues. I don't have this problem with pdflatex. Is there a way to solve this problem?

  • Normally this should only happen once after a change in the fonts -- it means that the cache is recreated -- if you get it all the time you could try fc-cache -f on a command line. – Ulrike Fischer Aug 16 '17 at 16:18
  • @UlrikeFischer: Yes. I run a file in which I didn't a font and then this problem appeared. I did what you said, but i got this message: C:/texlive/2017/texmf-var/fonts/cache\d031bbba323fd9e5b47e0ee5a0353f11-x86.cache -7: Permission denied. I have a windows 7 machine. – Sisabe Aug 16 '17 at 16:24
  • Check if the permission denied was only tempory: close everything restart the computer and then try again. If the problem persists you will have to find out who is denying the access. If fc-cache can't create the cache, xelatex probably can't neither, and then it is not wonder that it tries it again at every compilation. – Ulrike Fischer Aug 16 '17 at 16:49
  • @UlrikeFischer: I tried fc-cache.exe -v -f -r on the command line and now it's Ok. Thank you. – Sisabe Aug 17 '17 at 12:26
  • OK. I added an answer to get the question from the unanswered list. – Ulrike Fischer Aug 17 '17 at 12:38
3

You get this pause when xetex is recreating the font cache. It normally does it if you added or changed fonts. In TeXlive 2017 and a current miktex the pause should happen only for one compilation.

If the problem doesn't go away you should run on a command line

fc-cache -f

(force) or

fc-cache -r

(really force)

perhaps along with -v which would either repair the font cache or at least give some message to get a clue why the cache can not be created correctly.

In TeX Live 2016 one should (due to a bug) call fc-cache -f always when fonts have been changed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.